aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kmail-account-wizard
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-12 01:13:52 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-11 20:51:56 -0300
commit94e696129e3fe527765b01d13ab0dfc52c2338ec (patch)
tree68fa024bbbf3d25d605e98f8ad0b9ec917a51ff3 /testing/kmail-account-wizard
parent6f8ea500006730ff5108378917be57dea5883ee3 (diff)
downloadaports-94e696129e3fe527765b01d13ab0dfc52c2338ec.tar.bz2
aports-94e696129e3fe527765b01d13ab0dfc52c2338ec.tar.xz
testing/kmail-account-wizard: new aport
Diffstat (limited to 'testing/kmail-account-wizard')
-rw-r--r--testing/kmail-account-wizard/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/kmail-account-wizard/APKBUILD b/testing/kmail-account-wizard/APKBUILD
new file mode 100644
index 0000000000..6af7e57286
--- /dev/null
+++ b/testing/kmail-account-wizard/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kmail-account-wizard
+pkgver=19.04.2
+pkgrel=0
+arch="all"
+url="https://kontact.kde.org/"
+pkgdesc="KMail account wizard"
+license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev kwallet-dev kcmutils-dev knotifyconfig-dev kconfig-dev kservice-dev kdbusaddons-dev kdoctools-dev ktexteditor-dev kcodecs-dev kcrash-dev knotifications-dev akonadi-dev kidentitymanagement-dev kldap-dev kmailtransport-dev pimcommon-dev libkdepim-dev libkleo-dev kimap-dev akonadi-mime-dev kross-dev knewstuff-dev gpgme-dev shared-mime-info"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="dea5ef9d49bc639bd1920f58aadc0341cfac1958a32b2ef6a77336c5f00d4458f433b242acaaeacc968cb05775e370d407a9c9a0612c81c240dbca5acd3dec4d kmail-account-wizard-19.04.2.tar.xz"