aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libkeduvocdocument/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-02 14:33:00 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-02 10:46:28 -0300
commitdfb93026a0d0c8dcc122c3a8ea85a59fa2bec942 (patch)
treecd83b93ff747ec4640f30b94fd5f43975aa6f8c1 /testing/libkeduvocdocument/APKBUILD
parent0da02cc2810dece7284ed8a6fee277a921d89291 (diff)
downloadaports-dfb93026a0d0c8dcc122c3a8ea85a59fa2bec942.tar.bz2
aports-dfb93026a0d0c8dcc122c3a8ea85a59fa2bec942.tar.xz
testing/libkeduvocdocument: new aport
Diffstat (limited to 'testing/libkeduvocdocument/APKBUILD')
-rw-r--r--testing/libkeduvocdocument/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/libkeduvocdocument/APKBUILD b/testing/libkeduvocdocument/APKBUILD
new file mode 100644
index 0000000000..68d4808a96
--- /dev/null
+++ b/testing/libkeduvocdocument/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libkeduvocdocument
+pkgver=19.08.0
+pkgrel=0
+arch="all"
+url="https://edu.kde.org"
+pkgdesc="Library to parse, convert, and manipulate KVTML files"
+license="GPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev ki18n-dev karchive-dev kio-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/libkeduvocdocument-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="82eedb6b4fde4c75cd97e96532f158510b446056bfd5c96766f72e731718c4d62157bc4862e11d1d50a19e6a782d57cf5661f689c57eab6c65fab54b79b77973 libkeduvocdocument-19.08.0.tar.xz"