aboutsummaryrefslogtreecommitdiffstats
path: root/testing/liblo/APKBUILD
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-17 15:40:52 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-18 09:04:49 +0000
commitb6640cc8048871170e653a12e95f631e62f1bc74 (patch)
tree1cf6e12ec25c682d868ed9b9dc16a806ad56ba94 /testing/liblo/APKBUILD
parent7d94753c99846d92a4c9656d2f7139c2d7410a53 (diff)
downloadaports-b6640cc8048871170e653a12e95f631e62f1bc74.tar.bz2
aports-b6640cc8048871170e653a12e95f631e62f1bc74.tar.xz
testing/liblo: new aport
http://liblo.sourceforge.net Open Sound Control protocol implementation for POSIX systems
Diffstat (limited to 'testing/liblo/APKBUILD')
-rw-r--r--testing/liblo/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/liblo/APKBUILD b/testing/liblo/APKBUILD
new file mode 100644
index 0000000000..2cc87dd6f9
--- /dev/null
+++ b/testing/liblo/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=liblo
+pkgver=0.31
+pkgrel=0
+pkgdesc="Open Sound Control protocol implementation for POSIX systems"
+url="http://liblo.sourceforge.net"
+arch="all"
+license="LGPL-2.1-or-later"
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/liblo/liblo-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="97f9561296c2e53f92db0cfee625687208b490f8bc229b6cffe88b43ca2a8da1ed3217aaa2151245ea483e54ad6c5e92b9cf10a20661766fa6d3bedb5a8cdd01 liblo-0.31.tar.gz"