aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libpostal
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-07 21:44:51 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 17:14:42 -0300
commitc6a805ed6764ea4bd17a657a292940b3a5138605 (patch)
tree5cb8cffbd00728e0f7eb7403613d719f2ae5a1a8 /testing/libpostal
parente9ac50da5a3afb2d6e9ac24f63bac4724d7435db (diff)
downloadaports-c6a805ed6764ea4bd17a657a292940b3a5138605.tar.bz2
aports-c6a805ed6764ea4bd17a657a292940b3a5138605.tar.xz
testing/libpostal: new aport
Diffstat (limited to 'testing/libpostal')
-rw-r--r--testing/libpostal/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/libpostal/APKBUILD b/testing/libpostal/APKBUILD
new file mode 100644
index 0000000000..ff104dd2c3
--- /dev/null
+++ b/testing/libpostal/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libpostal
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A C library for parsing/normalizing street addresses around the world"
+url="https://github.com/openvenues/libpostal"
+arch="all"
+license="MIT"
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-static $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/openvenues/libpostal/archive/v$pkgver.tar.gz"
+options="!check" # Requires 100GB of data
+
+prepare() {
+ default_prepare
+
+ ./bootstrap.sh
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/local/share \
+ --disable-data-download
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="90937c250cd2abc9af4924ca1636ae3b719f70be563e41762852f3140abcee04ed0804131cccc095b79ffb00837507ae0b91774abf4b4f854212a541dd1721a8 libpostal-1.0.0.tar.gz"