aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libretro-o2em/APKBUILD
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-06 15:03:48 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-06 22:35:35 +0000
commitf5ee7c43548dded3c71b4f6bad5326eb85838ba3 (patch)
treea5ec34e1ea546b775ad3f44e66045ca87c8c940f /testing/libretro-o2em/APKBUILD
parent87e1b96b6029f2504f095fea00e847579858f04d (diff)
downloadaports-f5ee7c43548dded3c71b4f6bad5326eb85838ba3.tar.bz2
aports-f5ee7c43548dded3c71b4f6bad5326eb85838ba3.tar.xz
testing/libretro-o2em: new aport
https://github.com/libretro/libretro-o2em port of O2EM to the libretro API, an Odyssey 2 / VideoPac emulator
Diffstat (limited to 'testing/libretro-o2em/APKBUILD')
-rw-r--r--testing/libretro-o2em/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/libretro-o2em/APKBUILD b/testing/libretro-o2em/APKBUILD
new file mode 100644
index 0000000000..6b33bab299
--- /dev/null
+++ b/testing/libretro-o2em/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-o2em
+pkgver=0_git20200203
+pkgrel=0
+_commit="b23a796dd3490e979ff43710317df6d43bd661e1"
+pkgdesc="port of O2EM to the libretro API, an Odyssey 2 / VideoPac emulator"
+url="https://github.com/libretro/libretro-o2em"
+arch="all"
+license="Artistic-2.0"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/libretro-o2em/archive/$_commit.tar.gz"
+builddir="$srcdir/libretro-o2em-$_commit"
+options="!check" # No tests
+
+build() {
+ make
+}
+
+package() {
+ install -Dm644 o2em_libretro.so "$pkgdir"/usr/lib/libretro/o2em_libretro.so
+}
+
+sha512sums="474342d2a5599f27940f7ba847187d2328ed5e8d1318388b4c636157d9787ab79e2b3669d0bbbf2d0c8a15e6fc8b424197097fca27f37bcf5aff7a83962c59a9 libretro-o2em-b23a796dd3490e979ff43710317df6d43bd661e1.tar.gz"