aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libretro-vba-next
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-06 21:06:44 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-06 20:28:17 +0000
commit6f476d77b14c21a25c4ba3fa47d84fcb1ba86140 (patch)
tree18ce46bf8facecda1874878011c0fd53ed197f01 /testing/libretro-vba-next
parent6b0054e26ee55bdd49c991ca8142678271553091 (diff)
downloadaports-6f476d77b14c21a25c4ba3fa47d84fcb1ba86140.tar.bz2
aports-6f476d77b14c21a25c4ba3fa47d84fcb1ba86140.tar.xz
testing/libretro-vba-next: new aport
https://github.com/libretro/vba-next optimized port of VBA-M to Libretro
Diffstat (limited to 'testing/libretro-vba-next')
-rw-r--r--testing/libretro-vba-next/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/libretro-vba-next/APKBUILD b/testing/libretro-vba-next/APKBUILD
new file mode 100644
index 0000000000..d5cee0e736
--- /dev/null
+++ b/testing/libretro-vba-next/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-vba-next
+pkgver=0_git20200106
+pkgrel=0
+_commit="019132daf41e33a9529036b8728891a221a8ce2e"
+pkgdesc="optimized port of VBA-M to Libretro"
+url="https://github.com/libretro/vba-next"
+arch="all"
+license="GPL-2.0-only"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/vba-next/archive/$_commit.tar.gz"
+builddir="$srcdir/vba-next-$_commit"
+options="!check" # No tests
+
+build() {
+ make -f Makefile.libretro
+}
+
+package() {
+ install -Dm644 vba_next_libretro.so "$pkgdir"/usr/lib/libretro/vba_next_libretro.so
+}
+
+sha512sums="7b99342cce7548e537a107c7060209195bb9bee6ba7b0b949a346356206d7152fdd4d61156087f2b6ea8b194d64b6f81e49753a42babf169a00789b220c26600 libretro-vba-next-019132daf41e33a9529036b8728891a221a8ce2e.tar.gz"