aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libsepol
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-02-07 19:45:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-02-07 20:02:33 +0000
commit9a8f66b0a2f615085618750f15f8259c7357cefa (patch)
tree257da286bf63cfbc411659405fe44654d58ef050 /testing/libsepol
parentf72934e8483d38bd378538e7151a9ebb901abbe4 (diff)
downloadaports-9a8f66b0a2f615085618750f15f8259c7357cefa.tar.bz2
aports-9a8f66b0a2f615085618750f15f8259c7357cefa.tar.xz
testing/libsepol: new aport
SELinux binary policy manipulation library https://github.com/SELinuxProject/selinux/wiki
Diffstat (limited to 'testing/libsepol')
-rw-r--r--testing/libsepol/APKBUILD34
-rw-r--r--testing/libsepol/symlink.patch11
2 files changed, 45 insertions, 0 deletions
diff --git a/testing/libsepol/APKBUILD b/testing/libsepol/APKBUILD
new file mode 100644
index 0000000000..3aa9ca63ec
--- /dev/null
+++ b/testing/libsepol/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsepol
+pkgver=2.5
+pkgrel=0
+pkgdesc="SELinux binary policy manipulation library "
+url="https://github.com/SELinuxProject/selinux/wiki"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev="bsd-compat-headers"
+makedepends="$depends_dev flex-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/libsepol-$pkgver.tar.gz
+ symlink.patch
+ "
+builddir="$srcdir/libsepol-$pkgver"
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="5b18e0e1e50bdf648c2c42241c42052c libsepol-2.5.tar.gz
+a6e22cdf108cf9cb71e8286b2890f590 symlink.patch"
+sha256sums="2bdeec56d0a08b082b93b40703b4b3329cc5562152f7254d8f6ef6b56afe850a libsepol-2.5.tar.gz
+65b701a3c611e9f5187e8d226a86c94faef59be18a72efb8721895985834dcbc symlink.patch"
+sha512sums="ea781a9a61ee7036abd221422f411451e15d01202de64b167c61886644d6e9ec81916dd770bc644ba2453ff177ac91f280be63df0e20b469b4f778ce3bfdedd9 libsepol-2.5.tar.gz
+e9c3d2b09963c4a7b2a82fe8150e5cbc1497305eec4cad4cd61f1f5466a6fc0f495d13efeef834c14ab0c8b3b6e034a4616038ff4b3e96e9373c68a5b30d843d symlink.patch"
diff --git a/testing/libsepol/symlink.patch b/testing/libsepol/symlink.patch
new file mode 100644
index 0000000000..ba35819720
--- /dev/null
+++ b/testing/libsepol/symlink.patch
@@ -0,0 +1,11 @@
+--- ./src/Makefile.orig
++++ ./src/Makefile
+@@ -70,7 +70,7 @@
+ install -m 755 $(LIBSO) $(SHLIBDIR)
+ test -d $(LIBDIR)/pkgconfig || install -m 755 -d $(LIBDIR)/pkgconfig
+ install -m 644 $(LIBPC) $(LIBDIR)/pkgconfig
+- ln -sf --relative $(SHLIBDIR)/$(LIBSO) $(LIBDIR)/$(TARGET)
++ ln -sf $(LIBSO) $(LIBDIR)/$(TARGET)
+
+ relabel:
+ /sbin/restorecon $(SHLIBDIR)/$(LIBSO)