aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libsignal-protocol-c/APKBUILD
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2019-11-26 13:16:24 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-26 15:13:01 +0100
commitb32328d4cbce94ac27472835d0c70075aa507edb (patch)
tree66d1bcd2668e6fec6e6d06dfee753367c0d76b82 /testing/libsignal-protocol-c/APKBUILD
parentdda4496be9df796314f44ebdcb532227ae559e7b (diff)
downloadaports-b32328d4cbce94ac27472835d0c70075aa507edb.tar.bz2
aports-b32328d4cbce94ac27472835d0c70075aa507edb.tar.xz
testing/libsignal-protocol-c: new aport
https://github.com/signalapp/libsignal-protocol-c Signal Protocol C Library testing/
Diffstat (limited to 'testing/libsignal-protocol-c/APKBUILD')
-rw-r--r--testing/libsignal-protocol-c/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/libsignal-protocol-c/APKBUILD b/testing/libsignal-protocol-c/APKBUILD
new file mode 100644
index 0000000000..2f978e2f61
--- /dev/null
+++ b/testing/libsignal-protocol-c/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname="libsignal-protocol-c"
+pkgver="2.3.2"
+pkgrel=0
+pkgdesc="Signal Protocol C Library"
+url="https://github.com/signalapp/libsignal-protocol-c"
+arch="all"
+license="GPL-3.0-only"
+makedepends="cmake"
+checkdepends="check-dev openssl-dev"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/signalapp/libsignal-protocol-c/archive/v$pkgver.tar.gz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=True \
+ -DBUILD_TESTING=1 \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS} .
+ make
+}
+
+check() {
+ cd tests
+ make
+ cd ../
+ ctest
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="7c63c42b9a590ed1a60a6f0094668d9948aa04e5965d052c22ae22b176df7c5582b8ec5c0e6c01ad582dfe2b04067380b9734ad08c64785242e90abcdabdfb8d libsignal-protocol-c-2.3.2.tar.gz"