aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libsoundio
diff options
context:
space:
mode:
authorMark Weston <markweston@cock.li>2019-09-03 22:32:56 +0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-04 10:48:29 -0300
commit2aeccffd83a814a8de4f82cca7c73e2ac9465eb1 (patch)
treeea13997a2ce391eeba7dc92025a96464ba92dd56 /testing/libsoundio
parent8373b1a9c77e1b470d0249024adf02f230b4401e (diff)
downloadaports-2aeccffd83a814a8de4f82cca7c73e2ac9465eb1.tar.bz2
aports-2aeccffd83a814a8de4f82cca7c73e2ac9465eb1.tar.xz
testing/libsoundio: new aport
Diffstat (limited to 'testing/libsoundio')
-rw-r--r--testing/libsoundio/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/libsoundio/APKBUILD b/testing/libsoundio/APKBUILD
new file mode 100644
index 0000000000..e2ad729f14
--- /dev/null
+++ b/testing/libsoundio/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mark Jynx <markjynx@cock.li>
+pkgname="libsoundio"
+pkgver="2.0.0"
+pkgrel=0
+pkgdesc="lightweight abstraction over various sound drivers"
+url="https://libsound.io"
+arch="all"
+options="!check" # No test suite.
+license="MIT"
+depends_dev="alsa-lib-dev"
+makedepends="cmake $depends_dev"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/andrewrk/libsoundio/archive/$pkgver.tar.gz"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_STATIC_LIBS=OFF \
+ -DBUILD_EXAMPLE_PROGRAMS=OFF \
+ -DBUILD_TESTS=OFF \
+ .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="347a9be1789a41e778ea8d0efa1d00e03e725a4ab65e3aaf6c71e49138643f08a50a81bd60087d86a3b4d63beaeec617e47ba6b81f829ece8a3ac17418eb5309 libsoundio-2.0.0.tar.gz"