aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libuninameslist
diff options
context:
space:
mode:
authorEd Robinson <ed.robinson@reevoo.com>2017-10-09 20:14:04 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-10-11 09:59:53 +0000
commit72916d5eb21e1c97f3cd3aba1e797562a126d57b (patch)
tree13ae0540eb5fbad2910b017d118095d0ba595610 /testing/libuninameslist
parent4c293b345ec917916f5b6cc54289ee3469006468 (diff)
downloadaports-72916d5eb21e1c97f3cd3aba1e797562a126d57b.tar.bz2
aports-72916d5eb21e1c97f3cd3aba1e797562a126d57b.tar.xz
testing/libuninameslist: new aport
Diffstat (limited to 'testing/libuninameslist')
-rw-r--r--testing/libuninameslist/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/libuninameslist/APKBUILD b/testing/libuninameslist/APKBUILD
new file mode 100644
index 0000000000..7ea628b4d3
--- /dev/null
+++ b/testing/libuninameslist/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Ed Robinson <ed@reevoo.com>
+# Maintainer: Ed Robinson <ed@reevoo.com>
+pkgname=libuninameslist
+pkgver=20170807
+pkgrel=0
+pkgdesc="A Library of Unicode names and annotation data"
+url="https://github.com/fontforge/libuninameslist"
+arch="all"
+license="BSD3"
+source="https://github.com/fontforge/$pkgname/releases/download/$pkgver/$pkgname-dist-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ autoreconf -i
+ automake --foreign
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="f7ff21bff4322251e35e6957abdb1f6a17a54032c094ec71f68a42156cc10095680e0ea9cfde4d26ed7139e9d10af6d3e901eb4de2c2e430febf472f61dc039e libuninameslist-dist-20170807.tar.gz"