aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libupnpp
diff options
context:
space:
mode:
authorMarvin Steadfast <marvin@xsteadfastx.org>2017-08-24 14:46:06 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-24 23:37:48 +0000
commitd399e11b41979b2218a6df5cc015e055315b2c54 (patch)
tree35e332f036cae905eaffef4c7f3f86e8f0ca647a /testing/libupnpp
parent6ea9289d7063c800011ee9f6e2c920831a2af7be (diff)
downloadaports-d399e11b41979b2218a6df5cc015e055315b2c54.tar.bz2
aports-d399e11b41979b2218a6df5cc015e055315b2c54.tar.xz
testing/libupnpp: new package
Diffstat (limited to 'testing/libupnpp')
-rw-r--r--testing/libupnpp/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/libupnpp/APKBUILD b/testing/libupnpp/APKBUILD
new file mode 100644
index 0000000000..7b39977b48
--- /dev/null
+++ b/testing/libupnpp/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marvin Steadfast <marvin@xsteadfastx.org>
+# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
+pkgname=libupnpp
+pkgver=0.15.3
+pkgrel=0
+pkgdesc="a C++ wrapper for libupnp"
+url="https://opensourceprojects.eu/p/libupnpp"
+arch="all"
+license="LGPL2+"
+options="!check"
+depends=""
+makedepends="curl-dev expat-dev libupnp-dev"
+install=""
+subpackages="$pkgname-dev"
+source="libupnpp-$pkgver.tar.gz::http://www.lesbonscomptes.com/upmpdcli/downloads/libupnpp-$pkgver.tar.gz"
+builddir="$srcdir/libupnpp-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8f2e28561691422a81874b988b99f29adeca38f6aeb9e54aaa85baddb184b0aca48abaa306b1adbf338c4e4525a11b4021e7ceb4a106f4fe683f00154b6b02e1 libupnpp-0.15.3.tar.gz"