aboutsummaryrefslogtreecommitdiffstats
path: root/testing/links-graphics/APKBUILD
diff options
context:
space:
mode:
authorJeremy O'Brien <neutral@fastmail.com>2019-10-07 16:47:13 -0400
committerRasmus Thomsen <oss@cogitri.dev>2019-10-15 19:06:12 +0200
commitab7bdc48174243acc167e9513f53c7de6f58c2e8 (patch)
treec0ba2915c610e984c69036e3a6b91561fad9d4d4 /testing/links-graphics/APKBUILD
parentf0bbc8e1701064c8de997cc4050cbbcd2145f9f1 (diff)
downloadaports-ab7bdc48174243acc167e9513f53c7de6f58c2e8.tar.bz2
aports-ab7bdc48174243acc167e9513f53c7de6f58c2e8.tar.xz
testing/links-graphics: new aport
http://links.twibright.com/ simple and fast web browser, with graphics enabled
Diffstat (limited to 'testing/links-graphics/APKBUILD')
-rw-r--r--testing/links-graphics/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/links-graphics/APKBUILD b/testing/links-graphics/APKBUILD
new file mode 100644
index 0000000000..efb20449d6
--- /dev/null
+++ b/testing/links-graphics/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jeremy O'Brien <neutral@fastmail.com>
+# Maintainer: Jeremy O'Brien <neutral@fastmail.com>
+pkgname=links-graphics
+pkgver=2.20.1
+pkgrel=0
+pkgdesc="Web browser running in both graphics and text mode"
+builddir="$srcdir"/links-$pkgver
+url="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links"
+arch="all"
+options="!check" # No test suite.
+license="GPL-2.0-or-later"
+subpackages="$pkgname-doc"
+makedepends="bzip2-dev openssl-dev zlib-dev libevent-dev zstd-dev xorg-server-dev jpeg-dev libpng-dev"
+provides="links"
+source="http://links.twibright.com/download/links-$pkgver.tar.bz2"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-javascript \
+ --enable-graphics \
+ --with-x \
+ --x-includes=/usr/include/X11/ \
+ --x-libraries=/usr/lib/xorg/ \
+ --disable-nls
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="c7258e303a2012e9016385abd1e8882ffec47dd3baf479a54448742e41b03508d874387af6ea97c7ef9c4d37f2eecbe7bc0121d923df79b0f455f4f466747ca2 links-2.20.1.tar.bz2"