aboutsummaryrefslogtreecommitdiffstats
path: root/testing/linux-tools
diff options
context:
space:
mode:
authorMinecrell <minecrell@minecrell.net>2020-04-08 14:39:57 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-20 08:31:31 +0000
commitb3a4a3daf1cb260f7e7a9f3f413c3feade91b6e3 (patch)
treef616325637828ca1a01ac72c60c221375805597b /testing/linux-tools
parent39cd04888d2f5c04ada5e43156a61e5a152464cb (diff)
downloadaports-b3a4a3daf1cb260f7e7a9f3f413c3feade91b6e3.tar.bz2
aports-b3a4a3daf1cb260f7e7a9f3f413c3feade91b6e3.tar.xz
testing/linux-tools: depend on all subpackages in root package
The root package doesn't really have a purpose otherwise.
Diffstat (limited to 'testing/linux-tools')
-rw-r--r--testing/linux-tools/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/testing/linux-tools/APKBUILD b/testing/linux-tools/APKBUILD
index 5903bd49ad..9175a90fb7 100644
--- a/testing/linux-tools/APKBUILD
+++ b/testing/linux-tools/APKBUILD
@@ -9,6 +9,7 @@ pkgdesc="Linux kernel tools meta package"
url="https://www.kernel.org/"
arch="all"
license="GPL-2.0-only"
+depends="perf cpupower $pkgname-gpio $pkgname-iio"
depends_dev="pciutils-dev readline-dev gettext-dev"
makedepends="$depends_dev elfutils-dev bash linux-headers flex bison diffutils
zlib-dev findutils"
@@ -51,6 +52,7 @@ package() {
cpupower() {
pkgdesc="Linux kernel tool to set CPU power features"
+ depends=""
mkdir -p "$subpkgdir"/usr/sbin \
"$subpkgdir"/usr/bin \
"$subpkgdir"/usr/lib \
@@ -64,6 +66,7 @@ cpupower() {
perf() {
pkgdesc="Linux kernel performance auditing tool"
+ depends=""
mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/bin/perf \
"$pkgdir"/usr/bin/trace \
@@ -75,12 +78,14 @@ perf() {
gpio() {
pkgdesc="Linux kernel GPIO tools"
+ depends=""
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/*gpio* "$subpkgdir"/usr/bin
}
iio() {
pkgdesc="Linux kernel IIO tools"
+ depends=""
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/*iio* "$subpkgdir"/usr/bin
}