aboutsummaryrefslogtreecommitdiffstats
path: root/testing/litespeed
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-10 14:46:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-10 16:14:35 +0000
commit996eb8d89469696ab8a55377818ac2aed478949e (patch)
treeb9bb56c31ee7de090f2d24d46c287dd388d0e19a /testing/litespeed
parente38d407f1156c45a0c83d740aef9a2e6d078bc9c (diff)
downloadaports-996eb8d89469696ab8a55377818ac2aed478949e.tar.bz2
aports-996eb8d89469696ab8a55377818ac2aed478949e.tar.xz
testing/litespeed: upgrade to 1.4.28
Diffstat (limited to 'testing/litespeed')
-rw-r--r--testing/litespeed/APKBUILD8
-rw-r--r--testing/litespeed/libressl.patch53
2 files changed, 58 insertions, 3 deletions
diff --git a/testing/litespeed/APKBUILD b/testing/litespeed/APKBUILD
index c3c4976c37..bb97e77374 100644
--- a/testing/litespeed/APKBUILD
+++ b/testing/litespeed/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=litespeed
-pkgver=1.4.27
+pkgver=1.4.28
pkgrel=0
_pkgreal=open$pkgname
_pkghome=var/lib/$pkgname
@@ -23,6 +23,7 @@ source="http://open.litespeedtech.com/packages/$_pkgreal-$pkgver.tgz
install.patch
ls_lock.patch
thread.patch
+ libressl.patch
"
builddir="$srcdir/$_pkgreal-$pkgver"
@@ -126,9 +127,10 @@ snmp() {
"$subpkgdir"/$_pkghome/add-ons
}
-sha512sums="ee31a178efc2b130529310d7ba78cd489758b57f44b427bdc075a5b6bd40d5a1678754158fcfd72b965b51a67a62a1f8e363f3f636b5f83e3303f231d3edbc11 openlitespeed-1.4.27.tgz
+sha512sums="caddf146bec216e06f7f7864d6cca712aba626e12a8cbf4fc6c2bf5e9bf277c035a0cbb24248c2140402bba604f075a0233aa50e133fe5205b4b7d2e2f6b3499 openlitespeed-1.4.28.tgz
2b0299246aaeb885122d8f939437f0e4701f6a79ea976f725ba8765d8b295c2797c0cac30e639d5eda665b9589710ee55acc4d03b078c4b9cc1e564994ccb9f5 litespeed.initd
827425bb9f2e5daea8ef69f79747785a56c09a33837c381a961f798d1110f89629324531c028e0010a51aa0639ba5c6be81b80b10779a23ae7f1f84dd7b0b596 include.patch
ead0ba0fabfb7d76a087f202d134bf86d909898e5d96e1330716c9288f21386d8b72f9caed34c095994a7ea328d7f8c9ae6d9e51a24e89b209099401ce09f2c5 install.patch
2211e6c787700fc08eaee56f049c80690ef53d2b14cfcf17099ed0e5dfbd28b76a7b30f0c8814901e3c72bd4fc63732196b6fa0a8231cc10f86ba5130810b3d6 ls_lock.patch
-c7775836ee13b082e5c2ce011673b1a30b5ca83765d6d81ff1359110ba970808de6a87cd6d61fd688c9d2037451598154b429d70ad25094b9e9f10938aea00fd thread.patch"
+c7775836ee13b082e5c2ce011673b1a30b5ca83765d6d81ff1359110ba970808de6a87cd6d61fd688c9d2037451598154b429d70ad25094b9e9f10938aea00fd thread.patch
+189aa909a54c69ab12ba401a889d7d2507af7c651cd77fdd0fb4a811702b699a094aa150f20dc9f6d1566518a6b7d04a21ac43a81f1cb34f7eca82df9287b36d libressl.patch"
diff --git a/testing/litespeed/libressl.patch b/testing/litespeed/libressl.patch
new file mode 100644
index 0000000000..c3476789a4
--- /dev/null
+++ b/testing/litespeed/libressl.patch
@@ -0,0 +1,53 @@
+diff --git a/src/sslpp/sslcontext.cpp b/src/sslpp/sslcontext.cpp
+index a701325..341b2da 100644
+--- a/src/sslpp/sslcontext.cpp
++++ b/src/sslpp/sslcontext.cpp
+@@ -723,7 +723,7 @@ int SslContext::enableSpdy(int level)
+ #ifdef TLSEXT_TYPE_application_layer_protocol_negotiation
+ SSL_CTX_set_alpn_select_cb(m_pCtx, SSLConntext_alpn_select_cb, this);
+ #endif
+-#ifdef TLSEXT_TYPE_next_proto_neg
++#if defined(TLSEXT_TYPE_next_proto_neg) || defined(LIBRESSL_VERSION_NUMBER)
+ SSL_CTX_set_next_protos_advertised_cb(m_pCtx,
+ SslConnection_ssl_npn_advertised_cb, this);
+ #else
+diff --git a/src/sslpp/sslutil.cpp b/src/sslpp/sslutil.cpp
+index 6561c04..afd9272 100644
+--- a/src/sslpp/sslutil.cpp
++++ b/src/sslpp/sslutil.cpp
+@@ -851,7 +851,16 @@ int SslUtil::getPrivateKeyPem(SSL_CTX *pCtx, AutoBuf *pBuf)
+ {
+ int ret = -1;
+ BIO *pOut = BIO_new(BIO_s_mem());
+- EVP_PKEY *pKey = SSL_CTX_get0_privatekey(pCtx);
++ EVP_PKEY *pKey = NULL;
++#if OPENSSL_VERSION_NUMBER >= 0x10002000L && !defined(LIBRESSL_VERSION_NUMBER)
++ pKey = SSL_CTX_get0_privatekey(pCtx);
++#else
++ SSL *ssl = SSL_new(pCtx);
++ if (!ssl)
++ return ret;
++ pKey = SSL_get_privatekey(ssl);
++ SSL_free(ssl);
++#endif
+
+ if (PEM_write_bio_PrivateKey(pOut, pKey, NULL, NULL, 0, NULL, NULL))
+ ret = bioToBuf(pOut, pBuf);
+@@ -863,7 +872,16 @@ int SslUtil::getCertPem(SSL_CTX *pCtx, AutoBuf *pBuf)
+ {
+ int ret = -1;
+ BIO *pOut = BIO_new(BIO_s_mem());
+- X509 *pCert = SSL_CTX_get0_certificate(pCtx);
++ X509 *pCert = NULL;
++#if OPENSSL_VERSION_NUMBER >= 0x10002000L && !defined(LIBRESSL_VERSION_NUMBER)
++ pCert = SSL_CTX_get0_certificate(pCtx);
++#else
++ SSL *ssl = SSL_new(pCtx);
++ if (!ssl)
++ return ret;
++ pCert = SSL_get_certificate(ssl);
++ SSL_free(ssl);
++#endif
+
+ if (PEM_write_bio_X509(pOut, pCert))
+ ret = bioToBuf(pOut, pBuf);