aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lldb/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-07 21:55:29 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-07 22:15:00 +0200
commiteab200a153b116760e101054091baf23e7093057 (patch)
tree128ee7a1e3339f46355f08a96d308768d4c08732 /testing/lldb/APKBUILD
parentf833bd30376a263fe3e0decd7e7c806174f8a396 (diff)
downloadaports-eab200a153b116760e101054091baf23e7093057.tar.bz2
aports-eab200a153b116760e101054091baf23e7093057.tar.xz
testing/lldb: move liblldb-intel-mpxtable.so out of /usr/bin
Diffstat (limited to 'testing/lldb/APKBUILD')
-rw-r--r--testing/lldb/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/lldb/APKBUILD b/testing/lldb/APKBUILD
index 67e1e0d09b..5f3264a6ca 100644
--- a/testing/lldb/APKBUILD
+++ b/testing/lldb/APKBUILD
@@ -53,6 +53,10 @@ package() {
DESTDIR="$pkgdir" ninja install
+ # XXX: I have no idea why this is installed to bindir. Moving it to
+ # libdir may break it, but I don't know how to test this.
+ mv "$pkgdir"/usr/bin/liblldb-intel-mpxtable.so "$pkgdir"/usr/lib/ || true
+
# Remove static libraries.
rm -f "$pkgdir"/usr/lib/*.a
}