aboutsummaryrefslogtreecommitdiffstats
path: root/testing/llvm-libunwind
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-12 01:25:22 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-12 01:25:22 +0200
commit9f4dcc969d23c8ecb1cdb497f888de08d9cc16cc (patch)
tree1a59c85c93980230bf3b3c947de9222e9b862bdd /testing/llvm-libunwind
parent0fd2a818797199b2413f81688dfbc5e1dfb4bd82 (diff)
downloadaports-9f4dcc969d23c8ecb1cdb497f888de08d9cc16cc.tar.bz2
aports-9f4dcc969d23c8ecb1cdb497f888de08d9cc16cc.tar.xz
testing/llvm-libunwind: disable on x86, fails to build
cd /home/buildozer/aports/testing/llvm-libunwind/src/libunwind-3.8.1.src/build-1/src && /usr/bin/cmake -E cmake_link_script CMakeFiles/unwind.dir/link.txt --verbose=1 /usr/bin/c++ -fPIC -Os -fomit-frame-pointer -fvisibility-inlines-hidden -Werror=date-time -std=c++11 -ffunction-sections -fdata-sections -Os -DNDEBUG -nodefaultlibs -Wl,--as-needed -Wl,-z,defs -shared -Wl,-soname,libunwind.so.1 -o ../lib/libunwind.so.1.0 CMakeFiles/unwind.dir/libunwind.cpp.o CMakeFiles/unwind.dir/Unwind-EHABI.cpp.o CMakeFiles/unwind.dir/UnwindLevel1.c.o CMakeFiles/unwind.dir/UnwindLevel1-gcc-ext.c.o CMakeFiles/unwind.dir/Unwind-sjlj.c.o CMakeFiles/unwind.dir/UnwindRegistersRestore.S.o CMakeFiles/unwind.dir/UnwindRegistersSave.S.o -lc -ldl -lpthread CMakeFiles/unwind.dir/libunwind.cpp.o: In function `libunwind::LocalAddressSpace::get8(unsigned int) [clone .isra.11]': libunwind.cpp:(.text._ZN9libunwind17LocalAddressSpace4get8Ej.isra.11+0x4c): undefined reference to `__stack_chk_fail_local' CMakeFiles/unwind.dir/libunwind.cpp.o: In function `libunwind::LocalAddressSpace::get16(unsigned int) [clone .isra.12]': libunwind.cpp:(.text._ZN9libunwind17LocalAddressSpace5get16Ej.isra.12+0x59): undefined reference to `__stack_chk_fail_local' CMakeFiles/unwind.dir/libunwind.cpp.o: In function `libunwind::LocalAddressSpace::get32(unsigned int) [clone .isra.13]': libunwind.cpp:(.text._ZN9libunwind17LocalAddressSpace5get32Ej.isra.13+0x58): undefined reference to `__stack_chk_fail_local' CMakeFiles/unwind.dir/libunwind.cpp.o: In function `libunwind::LocalAddressSpace::get64(unsigned int) [clone .isra.14]': libunwind.cpp:(.text._ZN9libunwind17LocalAddressSpace5get64Ej.isra.14+0x59): undefined reference to `__stack_chk_fail_local' CMakeFiles/unwind.dir/libunwind.cpp.o: In function `libunwind::UnwindCursor<libunwind::LocalAddressSpace, libunwind::Registers_x86>::getFunctionName(char*, unsigned int, unsigned long long*)': libunwind.cpp:(.text._ZN9libunwind12UnwindCursorINS_17LocalAddressSpaceENS_13Registers_x86EE15getFunctionNameEPcjPy[_ZN9libunwind12UnwindCursorINS_17LocalAddressSpaceENS_13Registers_x86EE15getFunctionNameEPcjPy]+0x87): undefined reference to `__stack_chk_fail_local' CMakeFiles/unwind.dir/libunwind.cpp.o:libunwind.cpp:(.text._ZN9libunwind14EHHeaderParserINS_17LocalAddressSpaceEE11decodeEHHdrERS1_jjRNS2_12EHHeaderInfoE[_ZN9libunwind14EHHeaderParserINS_17LocalAddressSpaceEE11decodeEHHdrERS1_jjRNS2_12EHHeaderInfoE]+0xe0): more undefined references to `__stack_chk_fail_local' follow collect2: error: ld returned 1 exit status
Diffstat (limited to 'testing/llvm-libunwind')
-rw-r--r--testing/llvm-libunwind/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/testing/llvm-libunwind/APKBUILD b/testing/llvm-libunwind/APKBUILD
index 3b373be057..9fdbfcd657 100644
--- a/testing/llvm-libunwind/APKBUILD
+++ b/testing/llvm-libunwind/APKBUILD
@@ -6,7 +6,7 @@ pkgver=3.8.1
pkgrel=0
pkgdesc="LLVM version of libunwind library"
url="http://llvm.org/"
-arch="all"
+arch="all !x86"
license="BSD"
depends_dev="!libunwind-dev"
makedepends="cmake llvm-dev"