aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lowjs
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-12-25 20:41:04 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-12-25 20:39:40 +0100
commitfb9e0cc78c1cd8c2b2dc7bf8ce900a2e30610693 (patch)
tree33d93cf62fdb2d50cbbc41f571b89cbbf2d3fb95 /testing/lowjs
parented20640a04872f7ab58e6e4428e1536b81141213 (diff)
downloadaports-fb9e0cc78c1cd8c2b2dc7bf8ce900a2e30610693.tar.bz2
aports-fb9e0cc78c1cd8c2b2dc7bf8ce900a2e30610693.tar.xz
testing/lowjs: try to fix build
I cannot reproduce it locally.
Diffstat (limited to 'testing/lowjs')
-rw-r--r--testing/lowjs/APKBUILD2
-rw-r--r--testing/lowjs/open62541-gcc9.patch3
2 files changed, 3 insertions, 2 deletions
diff --git a/testing/lowjs/APKBUILD b/testing/lowjs/APKBUILD
index 7a741199ff..8c30b77e7d 100644
--- a/testing/lowjs/APKBUILD
+++ b/testing/lowjs/APKBUILD
@@ -77,7 +77,7 @@ sha512sums="f567f60da89ccd710486e2d54e00298b9a8f0e337c32c93b678bc4c3f97eddd77582
e7f4eaf3f5cb8c791a25c9a1a213953423c6e063d7e3049ccab70fee977bfb4949e23aed50d9720539b798dc9d2e65227bca165ad4faa04797318492b4f06cfc duktape-44ca54f726bfa651a7ab59286dd5c371dba2ddfc.tar.gz
b8aecec6aa87eb2ab7ffecaca1989f922042ee534612229872bad10bc0e304951cb66a1d1aa3ba4e76384ca2ea28b8c5b7176eacf6b7df3d59ea7435b7894a48 use-npm-ci.patch
f1ce54e839160f559b31d588cc61b068b28e7844d4f6987f17396d7dfee8417ae861896742c746131c25686204c729f305610644c5526963622c4a8bc5517b41 lib-path.patch
-460b7a8fc4d328c7315985bef880a3fbb20c9459f27d8e6ad49f098a0e8edc787756a89ac9e7f7acecb3b860f6e70d1348842092261df39770b72cbeb710e81d open62541-gcc9.patch
+c2c7f10d327d2e56d2824db02c647c05773c652179f40eff7b376dfbf7eecd72b7d07c18458d59fd195993b261cb9a48e9f521ccb1a519807270c036ed8d5746 open62541-gcc9.patch
a0ff4c6ad0891be0d8246cd2cddd7d6015d948778ec52e49fcd1eb8da53c2b7f861b3d38e52f3bf7ec1ad6c2cdba35657cee7dddeb1e7e77e9430995cce23291 unbundle-c-ares.patch
d90f1f16390530cc328804f8232f821217a705e12e8d3cd47b787f779ec2f9cafbb7416c05d8d8ed96cc71e52bd86deee8deffded80ee297c50735998b9af70e unbundle-mbedtls.patch
577653248d6e80cf7065f2b763355bdd1a24853821643a4b14e768e32ae8b88db08ad9820549a7cf49ea1462d0d920a5008fd158a35afebdde5784b48e51718c make-flags.patch
diff --git a/testing/lowjs/open62541-gcc9.patch b/testing/lowjs/open62541-gcc9.patch
index 9e080dae20..3e0b885cbe 100644
--- a/testing/lowjs/open62541-gcc9.patch
+++ b/testing/lowjs/open62541-gcc9.patch
@@ -2,12 +2,13 @@ Adjust compile flags for open62541 to build with gcc 9.
--- a/deps/open62541/CMakeLists.txt
+++ b/deps/open62541/CMakeLists.txt
-@@ -407,6 +407,8 @@
+@@ -407,6 +407,9 @@
-Wc++-compat
-fno-strict-aliasing # fewer compiler assumptions about pointer types
-fexceptions # recommended for multi-threaded C code, also in combination with C++ code
+ -Wno-cast-function-type
+ -Wno-restrict
++ -Wno-sign-conversion
)
set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")