aboutsummaryrefslogtreecommitdiffstats
path: root/testing/luapak
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-29 23:23:19 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-29 23:23:57 +0200
commit4d0c50eaa0cd0ec122e4d50d5e8c39dc88f48436 (patch)
tree2368a63ce4938289968aa9e8d8aa633b079cc8ee /testing/luapak
parent23b6e159f41eecf66c4822a6f0ab800992189285 (diff)
downloadaports-4d0c50eaa0cd0ec122e4d50d5e8c39dc88f48436.tar.bz2
aports-4d0c50eaa0cd0ec122e4d50d5e8c39dc88f48436.tar.xz
testing/luapak: new aport
https://github.com/jirutka/luapak Easily build a standalone executable for any Lua program
Diffstat (limited to 'testing/luapak')
-rw-r--r--testing/luapak/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/luapak/APKBUILD b/testing/luapak/APKBUILD
new file mode 100644
index 0000000000..f338de07c4
--- /dev/null
+++ b/testing/luapak/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=luapak
+pkgver=0.1.0_beta2
+_pkgver=${pkgver/_/.}
+pkgrel=0
+pkgdesc="Easily build a standalone executable for any Lua program"
+url="https://github.com/jirutka/luapak"
+arch="noarch"
+license="MIT"
+_luaver=5.3
+depends="lua$_luaver
+ lua$_luaver-depgraph
+ lua$_luaver-glob-pattern
+ lua$_luaver-filesystem
+ lua$_luaver-optparse
+ luarocks$_luaver
+ binutils
+ gcc
+ libc-dev
+ lua$_luaver-dev
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$_pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$_pkgver"
+options="!check" # upstream does not provide tests yet
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ sed -i "s|#!/usr/bin/env lua|#!/usr/bin/lua$_luaver|" \
+ luapak/cli/init.lua
+}
+
+package() {
+ local lmod_dir="$pkgdir/usr/share/lua/$_luaver"
+ cd "$builddir"
+
+ mkdir -p "$lmod_dir"
+ cp -r luapak "$lmod_dir"/
+
+ install -m 755 -D luapak/cli/init.lua "$pkgdir"/usr/bin/luapak
+}
+
+sha512sums="898615faae1c97eec7b9d4f36be23fe22bed10e06627d27b90d4a0c956d4fe125ec2ecd3098fd598d92b8654c0e0edc2f7de2028f8274e49f35b37b4012b1b98 luapak-0.1.0_beta2.tar.gz"