aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxpanel
diff options
context:
space:
mode:
authork0r10n <k0r10n.dev@gmail.com>2014-09-17 07:59:24 +0400
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-17 14:55:05 +0000
commita5d8b21b59e347283cdab802e9b10430d03a9447 (patch)
tree42eabb2d4dfa9dbcbe8118a1a16f6a1ff3ddf0c2 /testing/lxpanel
parent16efcf09cc29ce9f6d3f1fb619064436bb8a0423 (diff)
downloadaports-a5d8b21b59e347283cdab802e9b10430d03a9447.tar.bz2
aports-a5d8b21b59e347283cdab802e9b10430d03a9447.tar.xz
testing/lxpanel: upgrade to 0.6.2
Diffstat (limited to 'testing/lxpanel')
-rw-r--r--testing/lxpanel/10-devproc-lxpanel-0.6.2.patch21
-rw-r--r--testing/lxpanel/APKBUILD41
2 files changed, 52 insertions, 10 deletions
diff --git a/testing/lxpanel/10-devproc-lxpanel-0.6.2.patch b/testing/lxpanel/10-devproc-lxpanel-0.6.2.patch
new file mode 100644
index 0000000000..aed0cc50ce
--- /dev/null
+++ b/testing/lxpanel/10-devproc-lxpanel-0.6.2.patch
@@ -0,0 +1,21 @@
+--- a/src/plugins/netstat/devproc.c
++++ b/src/plugins/netstat/devproc.c
+@@ -25,15 +25,15 @@
+ #include <net/if.h>
+ #include <net/if_arp.h>
+ #include <arpa/inet.h>
+-#include <linux/sockios.h>
+-#include <linux/types.h>
+-#include <linux/ethtool.h>
+ #include <iwlib.h>
+ #include "nsconfig.h"
+ #include "netstat.h"
+ #include "statusicon.h"
+ #include "devproc.h"
+ #include "dbg.h"
++#include <linux/sockios.h>
++#include <linux/types.h>
++#include <linux/ethtool.h>
+
+ /* network device list */
+ static void netproc_netdevlist_add(NETDEVLIST_PTR *netdev_list,
diff --git a/testing/lxpanel/APKBUILD b/testing/lxpanel/APKBUILD
index 2c74deb3ec..6325701050 100644
--- a/testing/lxpanel/APKBUILD
+++ b/testing/lxpanel/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
pkgname=lxpanel
-pkgver=0.6.1
+pkgver=0.6.2
pkgrel=1
pkgdesc='Lightweight X11 desktop panel'
arch='all'
@@ -9,23 +9,44 @@ url='http://lxde.org/'
license='GPL'
makedepends='gtk+2.0-dev alsa-lib-dev menu-cache-dev libwnck-dev
wireless-tools-dev docbook-xml docbook-xsl intltool'
-subpackages="$pkgname-doc $pkgname-dev"
-source="http://downloads.sourceforge.net/sourceforge/lxde/lxpanel-$pkgver.tar.gz"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
+source="http://downloads.sourceforge.net/sourceforge/lxde/lxpanel-$pkgver.tar.gz
+ 10-devproc-lxpanel-0.6.2.patch"
+
+_builddir="$srcdir"/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
CFLAGS="$CFLAGS -lgmodule-2.0" ./configure \
- --sysconfdir=/etc \
+ --build=$CBUILD \
+ --host=$CHOST \
--prefix=/usr \
- --enable-man || return 1
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
make || return 1
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="e96e191c4ffb7b475a6ba06455ecf7fa lxpanel-0.6.1.tar.gz"
-sha256sums="a16a21b2186218c70ed98dc7875c54d6bb12ae7271825ff5060feb8d2a4e86cb lxpanel-0.6.1.tar.gz"
-sha512sums="a0a67cad6899c286d69bc2b10b41bc277217b0452fea4e4be3bb8d68f524c6f4b878594961ad3acd187e90b3e96ff0aa0c97018c7bd5b198df64761c8378daa3 lxpanel-0.6.1.tar.gz"
+md5sums="b074182b6effe46ccac97bf178de4e32 lxpanel-0.6.2.tar.gz
+87ef3f86b272d1f50f6b0e770e40b095 10-devproc-lxpanel-0.6.2.patch"
+sha256sums="f9ba6d0b825f7b99de045c3371738792bf9f3604af66bef4d98d783461c60a48 lxpanel-0.6.2.tar.gz
+28afcd7f3cc1e2eec84d93ff49468224507b5d824c5692bb5915a2c90b6b2275 10-devproc-lxpanel-0.6.2.patch"
+sha512sums="bd80f3cc9ff288a362e733fd26c31a90169d467f01f6df468bc6efb2a3c6ce4feeedba509a8562327bb0e21cf0ee56f4d42b7f4ca802622fa958e7e1b1a03f10 lxpanel-0.6.2.tar.gz
+bf161826515ac031dfe035f9133167c4d3f42b40bf42732ef74166f6af9aeffc0195dc6c5326e8cb301f4efb4e299378997ef16908dd64e992470a5d4d03563d 10-devproc-lxpanel-0.6.2.patch"