aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mapnik
diff options
context:
space:
mode:
authorMarkus Juenemann <markus@juenemann.net>2016-12-10 11:15:09 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-02-07 14:30:51 +0000
commitc4ca6089d15b5936f661534b7ecf72f950e8cd1b (patch)
treecd2398656ecee3e05e01b02ad1b34721fc1dd9eb /testing/mapnik
parent076199c72dfb1f911df75c192e7dd143ded31209 (diff)
downloadaports-c4ca6089d15b5936f661534b7ecf72f950e8cd1b.tar.bz2
aports-c4ca6089d15b5936f661534b7ecf72f950e8cd1b.tar.xz
testing/mapnik: new aport
Added mapnik, mapnik-dev and mapnik-doc packages (http://mapnik.org/). [TT: fixed build parallelism, to not rebuild on install, and pkgver]
Diffstat (limited to 'testing/mapnik')
-rw-r--r--testing/mapnik/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/mapnik/APKBUILD b/testing/mapnik/APKBUILD
new file mode 100644
index 0000000000..afd0a74015
--- /dev/null
+++ b/testing/mapnik/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Markus Juenemann <markus@juenemann.net>
+# Maintainer: Markus Juenemann <markus@juenemann.net>
+pkgname=mapnik
+pkgver=3.0.12
+pkgrel=0
+pkgdesc="An open source toolkit for developing mapping applications"
+url="http://mapnik.org/"
+arch="all"
+license="LPGL2+"
+depends="boost boost-regex freetype zlib harfbuzz postgresql-client sqlite-libs cairo libpng libjpeg tiff libwebp libxml2 proj4 gdal icu"
+depends_dev=""
+makedepends="$depends_dev python scons boost-dev freetype-dev zlib-dev harfbuzz-dev postgresql-dev sqlite-dev cairo-dev libpng-dev tiff-dev libwebp-dev libxml2-dev proj4-dev gdal-dev icu-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/mapnik/mapnik/releases/download/v$pkgver/mapnik-v$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-v$pkgver"
+build() {
+ cd "$builddir"
+ python scons/scons.py configure PREFIX=/usr DESTDIR="$pkgdir" --jobs=${JOBS-2} --config=cache --implicit-cache --max-drift=1 || return 1
+ python scons/scons.py --jobs=${JOBS-2} --config=cache --implicit-cache --max-drift=1
+}
+
+package() {
+ cd "$builddir"
+ python scons/scons.py install --jobs=${JOBS-2} --config=cache --implicit-cache --max-drift=1
+}
+
+dev() {
+ pkgdesc="Mapnik development files"
+ mkdir -p "$subpkgdir"/usr/include/mapnik || return 1
+ mv "$pkgdir"/usr/include/mapnik "$subpkgdir"/usr/include/mapnik || return 1
+}
+
+doc() {
+ pkgdesc="Mapnik documentation"
+ mkdir -p "$subpkgdir"/usr/share/docs/$pkgname/docs/ || return 1
+ install -Dm644 $builddir/*.md "$subpkgdir"/usr/share/docs/$pkgname/
+ install -Dm644 $builddir/docs/* "$subpkgdir"/usr/share/docs/$pkgname/docs/
+}
+
+md5sums="221c1fa8e63f4cc93b3040e9382e3394 mapnik-v3.0.12.tar.bz2"
+sha256sums="66a3d620c3ce543c91ea5b42a25079aca9a2a90f6079a2ce2a8714398fa57d6d mapnik-v3.0.12.tar.bz2"
+sha512sums="db87cd76f21b46e1b92d303f02b4c3927e520e7b309f717967283831adfec53f15aab23e7e737ee4a79ff2c06948b94df7d193621aff99197d4dede9a4e329b7 mapnik-v3.0.12.tar.bz2"