aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mblaze
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-20 12:54:32 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-20 12:54:32 +0200
commita1e0975ef1402722cc0a69fab450dd6730cf067a (patch)
tree594285a4dd5fc4775078027a6ff63c31432119de /testing/mblaze
parent580465b6718443236377773cbc1c1c966545b2a8 (diff)
downloadaports-a1e0975ef1402722cc0a69fab450dd6730cf067a.tar.bz2
aports-a1e0975ef1402722cc0a69fab450dd6730cf067a.tar.xz
testing/mblaze: new aport
Diffstat (limited to 'testing/mblaze')
-rw-r--r--testing/mblaze/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/mblaze/APKBUILD b/testing/mblaze/APKBUILD
new file mode 100644
index 0000000000..43cbfe4b22
--- /dev/null
+++ b/testing/mblaze/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=mblaze
+pkgver=0.2
+pkgrel=0
+pkgdesc="Unix utilities to deal with Maildir"
+url="https://github.com/chneukirchen/mblaze"
+arch="all"
+license="public domain"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+options="!check"
+source="https://github.com/chneukirchen/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ make -C "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples/
+ install -m644 *.example "$pkgdir"/usr/share/doc/$pkgname/examples/
+ install -m644 NEWS.md VIOLATIONS.md README \
+ "$pkgdir"/usr/share/doc/$pkgname/
+}
+
+sha512sums="7bbe8285cd1453e5b79e0b4af7ef38e0a4d24aa3317530480be2a89554cae0afa47f18e159ee976930dcea95fd92e07ab534a57c98f8cef42c37f5dce709fa12 mblaze-0.2.tar.gz"