aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mblaze
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-22 18:24:27 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-22 19:50:45 +0200
commitd9ec017a2123cfb564d97b453ecf1b0de00b5d63 (patch)
tree3b950536f0cc6ac07536d0466935ccc65863611f /testing/mblaze
parent8a7e358d4760aa8de74ea323f5df954f19a70fba (diff)
downloadaports-d9ec017a2123cfb564d97b453ecf1b0de00b5d63.tar.bz2
aports-d9ec017a2123cfb564d97b453ecf1b0de00b5d63.tar.xz
testing/mblaze: backport fix for compatibility with busybox sed
Diffstat (limited to 'testing/mblaze')
-rw-r--r--testing/mblaze/0001-mgenmid-printb36-fix-off-by-one.patch2
-rw-r--r--testing/mblaze/0002-mquote-make-sed-expression-to-strip-signature-work-w.patch26
-rw-r--r--testing/mblaze/APKBUILD8
3 files changed, 32 insertions, 4 deletions
diff --git a/testing/mblaze/0001-mgenmid-printb36-fix-off-by-one.patch b/testing/mblaze/0001-mgenmid-printb36-fix-off-by-one.patch
index 5ab1d6d29e..23bcfec55c 100644
--- a/testing/mblaze/0001-mgenmid-printb36-fix-off-by-one.patch
+++ b/testing/mblaze/0001-mgenmid-printb36-fix-off-by-one.patch
@@ -1,7 +1,7 @@
From 6f99ef55a8bd75d99882078b50e3c7665106c514 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Mon, 21 Aug 2017 19:40:00 +0200
-Subject: [PATCH] mgenmid: printb36: fix off-by-one
+Subject: [PATCH 1/2] mgenmid: printb36: fix off-by-one
Closes #73.
---
diff --git a/testing/mblaze/0002-mquote-make-sed-expression-to-strip-signature-work-w.patch b/testing/mblaze/0002-mquote-make-sed-expression-to-strip-signature-work-w.patch
new file mode 100644
index 0000000000..b0948c81f1
--- /dev/null
+++ b/testing/mblaze/0002-mquote-make-sed-expression-to-strip-signature-work-w.patch
@@ -0,0 +1,26 @@
+From dfe09a7c5e3a2273f963d53432ef1686b34547db Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
+Date: Mon, 21 Aug 2017 21:34:14 +0200
+Subject: [PATCH 2/2] mquote: make sed expression to strip signature work with
+ busybox sed
+
+Closes: #74 [via git-merge-pr]
+---
+ mquote | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mquote b/mquote
+index a64000d..fa8e4a4 100755
+--- a/mquote
++++ b/mquote
+@@ -7,6 +7,6 @@
+
+ printf '%s wrote:\n' "$from"
+ mshow -R "$1" |
+- sed -n '/^-- $/!p;//q' | # strip signature
++ sed -n '/^-- $/,$!p' | # strip signature
+ sed -e :a -e '/^\n*$/{$d;N;ba' -e '}' | # strip empty lines
+ sed 's/^/> /' # prefix with >
+--
+2.14.1
+
diff --git a/testing/mblaze/APKBUILD b/testing/mblaze/APKBUILD
index efb80ecfe4..f3289bfd20 100644
--- a/testing/mblaze/APKBUILD
+++ b/testing/mblaze/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=mblaze
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Unix utilities to deal with Maildir"
url="https://github.com/chneukirchen/mblaze"
arch="all"
@@ -14,7 +14,8 @@ install=""
subpackages="$pkgname-doc"
options="!check"
source="https://github.com/chneukirchen/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
- 0001-mgenmid-printb36-fix-off-by-one.patch"
+ 0001-mgenmid-printb36-fix-off-by-one.patch
+ 0002-mquote-make-sed-expression-to-strip-signature-work-w.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -32,4 +33,5 @@ package() {
}
sha512sums="7bbe8285cd1453e5b79e0b4af7ef38e0a4d24aa3317530480be2a89554cae0afa47f18e159ee976930dcea95fd92e07ab534a57c98f8cef42c37f5dce709fa12 mblaze-0.2.tar.gz
-4e4b6f870daf28cee16f3a2d7830ad92635ec071385157e0a9edb97019c1ecc84055f25d6d8432daa225bbecb69d11415568d289be29e5d1dd8922dcc1c619ac 0001-mgenmid-printb36-fix-off-by-one.patch"
+60625a0be19b401a9329246f827903fe32a8cffa82e3b1b9ce68dc1faf54aa0620fa9f0355396a6053b48fe22bd8b8bcd178795cfc813f4231b08db5aa9e0baf 0001-mgenmid-printb36-fix-off-by-one.patch
+2dba93430e2c855c12e19faace111404d07dda495012296896068d07347bd9bff018c102e2d4fbdf5fd9fc49b2748c8fdbdb722aab5ef36b050f89c4475d962c 0002-mquote-make-sed-expression-to-strip-signature-work-w.patch"