aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mblaze
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-02-14 09:08:22 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-02-14 09:47:34 +0100
commitfa02ec94000d1cf0cc675e3d834d9249f0fbbf79 (patch)
treef0f5e0128efbebad2941a681cd00b710d9bb4f82 /testing/mblaze
parent45687eec04fd514e4d01a7a010a89fa32fdc455c (diff)
downloadaports-fa02ec94000d1cf0cc675e3d834d9249f0fbbf79.tar.bz2
aports-fa02ec94000d1cf0cc675e3d834d9249f0fbbf79.tar.xz
testing/mblaze: upgrade to 0.3.2
Diffstat (limited to 'testing/mblaze')
-rw-r--r--testing/mblaze/0001-mgenmid-printb36-fix-off-by-one.patch29
-rw-r--r--testing/mblaze/0002-mquote-make-sed-expression-to-strip-signature-work-w.patch26
-rw-r--r--testing/mblaze/APKBUILD14
3 files changed, 5 insertions, 64 deletions
diff --git a/testing/mblaze/0001-mgenmid-printb36-fix-off-by-one.patch b/testing/mblaze/0001-mgenmid-printb36-fix-off-by-one.patch
deleted file mode 100644
index 23bcfec55c..0000000000
--- a/testing/mblaze/0001-mgenmid-printb36-fix-off-by-one.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 6f99ef55a8bd75d99882078b50e3c7665106c514 Mon Sep 17 00:00:00 2001
-From: Leah Neukirchen <leah@vuxu.org>
-Date: Mon, 21 Aug 2017 19:40:00 +0200
-Subject: [PATCH 1/2] mgenmid: printb36: fix off-by-one
-
-Closes #73.
----
- mgenmid.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/mgenmid.c b/mgenmid.c
-index 36aa8c8..655df95 100644
---- a/mgenmid.c
-+++ b/mgenmid.c
-@@ -21,9 +21,10 @@ printb36(uint64_t x)
-
- char outbuf[16];
- char *o = outbuf + sizeof outbuf;
-- *o = 0;
-
-+ *--o = 0;
- do { *--o = base36[x % 36]; } while (x /= 36);
-+
- fputs(o, stdout);
- }
-
---
-2.14.1
-
diff --git a/testing/mblaze/0002-mquote-make-sed-expression-to-strip-signature-work-w.patch b/testing/mblaze/0002-mquote-make-sed-expression-to-strip-signature-work-w.patch
deleted file mode 100644
index b0948c81f1..0000000000
--- a/testing/mblaze/0002-mquote-make-sed-expression-to-strip-signature-work-w.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From dfe09a7c5e3a2273f963d53432ef1686b34547db Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
-Date: Mon, 21 Aug 2017 21:34:14 +0200
-Subject: [PATCH 2/2] mquote: make sed expression to strip signature work with
- busybox sed
-
-Closes: #74 [via git-merge-pr]
----
- mquote | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mquote b/mquote
-index a64000d..fa8e4a4 100755
---- a/mquote
-+++ b/mquote
-@@ -7,6 +7,6 @@
-
- printf '%s wrote:\n' "$from"
- mshow -R "$1" |
-- sed -n '/^-- $/!p;//q' | # strip signature
-+ sed -n '/^-- $/,$!p' | # strip signature
- sed -e :a -e '/^\n*$/{$d;N;ba' -e '}' | # strip empty lines
- sed 's/^/> /' # prefix with >
---
-2.14.1
-
diff --git a/testing/mblaze/APKBUILD b/testing/mblaze/APKBUILD
index 36d9aebadd..3debcad8fd 100644
--- a/testing/mblaze/APKBUILD
+++ b/testing/mblaze/APKBUILD
@@ -1,21 +1,19 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer:
pkgname=mblaze
-pkgver=0.2
-pkgrel=2
+pkgver=0.3.2
+pkgrel=0
pkgdesc="Unix utilities to deal with Maildir"
url="https://github.com/chneukirchen/mblaze"
arch="all"
-license="Public-Domain"
+license="CC0-1.0"
depends=""
depends_dev=""
makedepends=""
install=""
subpackages="$pkgname-doc"
options="!check"
-source="https://github.com/chneukirchen/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
- 0001-mgenmid-printb36-fix-off-by-one.patch
- 0002-mquote-make-sed-expression-to-strip-signature-work-w.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/chneukirchen/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -32,6 +30,4 @@ package() {
"$pkgdir"/usr/share/doc/$pkgname/
}
-sha512sums="7bbe8285cd1453e5b79e0b4af7ef38e0a4d24aa3317530480be2a89554cae0afa47f18e159ee976930dcea95fd92e07ab534a57c98f8cef42c37f5dce709fa12 mblaze-0.2.tar.gz
-60625a0be19b401a9329246f827903fe32a8cffa82e3b1b9ce68dc1faf54aa0620fa9f0355396a6053b48fe22bd8b8bcd178795cfc813f4231b08db5aa9e0baf 0001-mgenmid-printb36-fix-off-by-one.patch
-2dba93430e2c855c12e19faace111404d07dda495012296896068d07347bd9bff018c102e2d4fbdf5fd9fc49b2748c8fdbdb722aab5ef36b050f89c4475d962c 0002-mquote-make-sed-expression-to-strip-signature-work-w.patch"
+sha512sums="809d3a82e89a90bf1dce5abca97155b524290bbaa3c8100efb461f3694c4ff28ed0d1e46d3d74c2fbb96a17cd44ccee315a022d6697a470f82d8d4ee66ab7147 mblaze-0.3.2.tar.gz"