aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mhddfs
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-13 23:10:19 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-07 13:05:02 +0000
commit5d9e0b7417aaf856c7205473ed15a07c5c9d33f2 (patch)
tree69974683b9802562175cf458e5bd0511f32f53dc /testing/mhddfs
parentb0ecd11773e984f7394bdf90da603e47267fab28 (diff)
downloadaports-5d9e0b7417aaf856c7205473ed15a07c5c9d33f2.tar.bz2
aports-5d9e0b7417aaf856c7205473ed15a07c5c9d33f2.tar.xz
testing/mhddfs: modernize abuild
Diffstat (limited to 'testing/mhddfs')
-rw-r--r--testing/mhddfs/APKBUILD27
1 files changed, 5 insertions, 22 deletions
diff --git a/testing/mhddfs/APKBUILD b/testing/mhddfs/APKBUILD
index 5d662cfdb8..6137447ad4 100644
--- a/testing/mhddfs/APKBUILD
+++ b/testing/mhddfs/APKBUILD
@@ -10,39 +10,22 @@ license="GPL3"
depends="fuse"
depends_dev="fuse-dev attr-dev"
makedepends="$depends_dev"
-install=""
-subpackages=""
_uthashver=1.9.9
source="http://mhddfs.uvw.ru/downloads/${pkgname}_${pkgver}.tar.gz
- saveas-https://github.com/troydhanson/uthash/archive/v${_uthashver}.tar.gz/uthash-v${_uthashver}.tar.gz
+ uthash-v${_uthashver}.tar.gz::https://github.com/troydhanson/uthash/archive/v${_uthashver}.tar.gz
local-uthash.patch"
-_builddir="$srcdir"/${pkgname}-${pkgver}
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/${pkgname}-${pkgver}
build() {
- cd "$_builddir"
+ cd "$builddir"
srcdir=${srcdir} make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
install -Dsm755 mhddfs "$pkgdir"/usr/bin/${pkgname}
}
-md5sums="efc43fa9b4c1437bb233149bd624a459 mhddfs_0.1.39.tar.gz
-c3ce9197c818dcb7ca85b59912f310a4 uthash-v1.9.9.tar.gz
-79f1cbe1b25e9e7d096614959aa5d420 local-uthash.patch"
-sha256sums="702fc5486460c1828898426b1935179ce60bc1ed16fc8bc575c9ec1d12acef91 mhddfs_0.1.39.tar.gz
-f2f10115f4de03b98d8c2e860e241d165aa15019bd634ee0e3debe58341bbf0c uthash-v1.9.9.tar.gz
-8243c699e243da20f8cb03ebf43548a069fe4b5737bc1e5841c816383708cfea local-uthash.patch"
+
sha512sums="cf1952e665e82a92ccfef9215d4faf78cd235566b67e6ebc3a60ab53089d9391bc41a08e6b203ad052e4a08bdd14428f2d9abe48f341aeb0c80ae1da80f83f89 mhddfs_0.1.39.tar.gz
40b888529db6baba7bdb0a11c3f782719c40470f6b8e4d75ed480c4c465606e990abf65786156a93f4e2f9c8805cbc098550cc3c62e33b7345fa5bf6d146a8c4 uthash-v1.9.9.tar.gz
e288ab2efad8955e621460e46dc6ec7c14f6471498ec3df6900fad00bfbb91d3ba9cabed10f17257c6aa15f5be6558c75d4220e57b935beb1cef0893d7a9bbab local-uthash.patch"