aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mkmr
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-13 19:43:51 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-13 19:44:08 -0300
commitfdb9b56ebbf90952a85d2de74421b7fff025c4d4 (patch)
treee5a5d16abb3e58e36d6e5eed1fa44f93dc875d98 /testing/mkmr
parentad2af3c18bb18513ddc0cca362617b4280399ae3 (diff)
downloadaports-fdb9b56ebbf90952a85d2de74421b7fff025c4d4.tar.bz2
aports-fdb9b56ebbf90952a85d2de74421b7fff025c4d4.tar.xz
testing/mkmr: new aport
https://github.com/maxice8/mkmr Make merge requests in any GitLab repo conveniently
Diffstat (limited to 'testing/mkmr')
-rw-r--r--testing/mkmr/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/mkmr/APKBUILD b/testing/mkmr/APKBUILD
new file mode 100644
index 0000000000..78841dcbc0
--- /dev/null
+++ b/testing/mkmr/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=mkmr
+pkgver=0.0.2
+pkgrel=0
+pkgdesc="Make merge requests in any GitLab repo conveniently"
+url="https://github.com/maxice8/mkmr"
+arch="all"
+license="GPL-3.0-or-later"
+depends="
+ python3
+ py3-setuptools
+ py3-gitlab
+ py3-gitpython
+ py3-python-editor
+ py3-inquirer
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/maxice8/mkmr/archive/$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3e06465b2d108a54519a1c8000fd168f791273c8f454172eebce5498ba1f29cfcd1a02a95970bdbc1c27b049de7f4c917c83d5df6087b1e7bbb331ae8575de09 mkmr-0.0.2.tar.gz"