aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mle
diff options
context:
space:
mode:
authorAdam Saponara <as@php.net>2020-02-15 22:28:30 -0500
committerLeo <thinkabit.ukim@gmail.com>2020-02-18 19:08:27 -0300
commita2086ccffdb0417ff9b059ec63bf79cf72b47be7 (patch)
treebc1f3fb328caf04b3ba7dc6aaf4e03a9e04488df /testing/mle
parentb1b5796d72ea5e0802e18640c54e90513f9b9836 (diff)
downloadaports-a2086ccffdb0417ff9b059ec63bf79cf72b47be7.tar.bz2
aports-a2086ccffdb0417ff9b059ec63bf79cf72b47be7.tar.xz
testing/mle: new aport
Diffstat (limited to 'testing/mle')
-rw-r--r--testing/mle/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/mle/APKBUILD b/testing/mle/APKBUILD
new file mode 100644
index 0000000000..914c6e7b37
--- /dev/null
+++ b/testing/mle/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Adam Saponara <as@php.net>
+# Maintainer: Adam Saponara <as@php.net>
+pkgname=mle
+pkgver=1.4.3
+pkgrel=0
+pkgdesc="Flexible terminal-based text editor"
+url="https://github.com/adsr/mle"
+arch="all"
+license="Apache-2.0"
+makedepends="uthash-dev termbox-dev lua5.3-dev pcre-dev"
+checkdepends="bash grep"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/adsr/mle/archive/v$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ sed -i 's/-llua5.3/-llua/g' Makefile
+}
+
+build() {
+ export CFLAGS="$CFLAGS -I/usr/include/lua5.3"
+ export LDFLAGS="$LDFLAGS -L/usr/lib/lua5.3"
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" prefix=/usr install
+ install -d "$pkgdir/usr/share/man/man1"
+ install -m644 mle.1 "$pkgdir"/usr/share/man/man1/
+}
+
+sha512sums="014a8834a088f410a9ef5cd213140f1e4386726bd277f5fdffdfff8165cd1460ede54d5cb62a26bdef804391a524d398a439977b8f82add3d365936a3c5505ab mle-1.4.3.tar.gz"