aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mod_auth_cas/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-08 18:34:59 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-07 08:20:37 -0300
commit030f5cfa916da4aa9d0ef7e2a229d187bbba2aeb (patch)
treea93f134b09e2bb6fc4afd1a94ad3d43d1eecfbe0 /testing/mod_auth_cas/APKBUILD
parentbb0921051311fb3090671abeac99983ef37a2f33 (diff)
downloadaports-030f5cfa916da4aa9d0ef7e2a229d187bbba2aeb.tar.bz2
aports-030f5cfa916da4aa9d0ef7e2a229d187bbba2aeb.tar.xz
testing/mod_auth_cas: upgrade to 1.2
Diffstat (limited to 'testing/mod_auth_cas/APKBUILD')
-rw-r--r--testing/mod_auth_cas/APKBUILD34
1 files changed, 12 insertions, 22 deletions
diff --git a/testing/mod_auth_cas/APKBUILD b/testing/mod_auth_cas/APKBUILD
index 7c60a5c879..0df9c31264 100644
--- a/testing/mod_auth_cas/APKBUILD
+++ b/testing/mod_auth_cas/APKBUILD
@@ -1,31 +1,19 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=mod_auth_cas
-pkgver=1.1
-pkgrel=4
+pkgver=1.2
+pkgrel=0
pkgdesc="An Apache httpd module for integrating with Apereo (JASIG) CAS Server project"
url="https://www.apereo.org/projects/cas"
arch="all"
-license="Apache"
-depends=""
-depends_dev=""
-makedepends="$depends_dev apache2-dev curl-dev pcre-dev
- autoconf automake libtool"
-install=""
-subpackages=""
-source="mod_auth_cas-$pkgver.tar.gz::https://github.com/Jasig/mod_auth_cas/archive/v$pkgver.tar.gz
+license="Apache-2.0"
+makedepends="apache2-dev curl-dev pcre-dev"
+source="
+ mod_auth_cas-$pkgver.tar.gz::https://github.com/Jasig/mod_auth_cas/archive/v$pkgver.tar.gz
remove-error.h.patch
- openssl-1.1.patch
"
-builddir="$srcdir/mod_auth_cas-$pkgver"
-
-prepare() {
- default_prepare
- autoreconf -vif
-}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -36,11 +24,13 @@ build() {
make
}
+check() {
+ make check
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="39625df051494f55cdbf5d703b0b1f244da6bb4e1a0609869158675c773abcef135e77cef32b70b4e5d5a59f82ea963a95929ae3880e367664e37c8a942c723a mod_auth_cas-1.1.tar.gz
-7e0d9dd6022e8a6243ca8650e189d3ca2a35301d9966cb7e3a31b99348d6b2cd3c3f75910fd8ea891c9f5f0ba89d1a047223b72ebcd9844121228e5909868679 remove-error.h.patch
-ffdd07f414cc8418bff68af85fd7b69c923288130b00742d85439f690bb6d90cec6f2fe3e61abaee035823acf0e6b46f54ce71dd8f2c0ee3582d6d7412db1a40 openssl-1.1.patch"
+sha512sums="e1ca75493ba6132c2c3d4d888bc3f25ad9674441d1f89fada64db515f4faf899ce655c1c09b0f6a4cd6169d6ac7d16901e062aa7cacd3b95ecfcd5d8ea030b6d mod_auth_cas-1.2.tar.gz
+7e0d9dd6022e8a6243ca8650e189d3ca2a35301d9966cb7e3a31b99348d6b2cd3c3f75910fd8ea891c9f5f0ba89d1a047223b72ebcd9844121228e5909868679 remove-error.h.patch"