aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monero
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2018-02-10 06:51:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-02-13 14:10:19 +0000
commit5de93beaf1f2f00f1d5ffc4f68407babd04e4caa (patch)
treedbac3c11bc43c593dfaa71d963548e317ab96c2f /testing/monero
parentff165e0266184a6999801abe52e4a993bda2210e (diff)
downloadaports-5de93beaf1f2f00f1d5ffc4f68407babd04e4caa.tar.bz2
aports-5de93beaf1f2f00f1d5ffc4f68407babd04e4caa.tar.xz
testing/monero: patch AES on s390x
Diffstat (limited to 'testing/monero')
-rw-r--r--testing/monero/APKBUILD6
-rw-r--r--testing/monero/disable-aes-on-s390x.patch31
2 files changed, 35 insertions, 2 deletions
diff --git a/testing/monero/APKBUILD b/testing/monero/APKBUILD
index 2787fa0d18..176829d12c 100644
--- a/testing/monero/APKBUILD
+++ b/testing/monero/APKBUILD
@@ -5,12 +5,13 @@ pkgver=0.11.1.0
pkgrel=1
pkgdesc="Secure, private, untraceable cryptocurrency"
url="https://getmonero.org/"
-arch="all !s390x"
+arch="all"
license="BSD"
makedepends="unbound-dev libressl-dev boost-dev miniupnpc-dev cmake"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/$pkgname/archive/v$pkgver.tar.gz
easylogging.patch
+ disable-aes-on-s390x.patch
"
builddir="$srcdir/"$pkgname-$pkgver
@@ -28,4 +29,5 @@ package() {
}
sha512sums="bac3520730164afe2ca992c588bd0b51791d986cd8d5ebcaac5bd48185b963e2391c28ee89399d7dd678a5d1f8b41c3ae5724d194a5f62bbcd3e6ad505986573 monero-0.11.1.0.tar.gz
-ff26308bdaf1e0aea9803ece5ec23bebb55d39169e9567c48f4cd4bdceb4fa75cd27fee5bd3d5050273936a3593a29dc2c9d7f5a8dd7a1e0b97a752c48ad4985 easylogging.patch"
+ff26308bdaf1e0aea9803ece5ec23bebb55d39169e9567c48f4cd4bdceb4fa75cd27fee5bd3d5050273936a3593a29dc2c9d7f5a8dd7a1e0b97a752c48ad4985 easylogging.patch
+32784d187f0c496468fdf5a31071e224a5772d4dab46c053b8d377e5680016d3b7a4fa71fde349e0f200e767b9732492eecd1928b90f3441dff7e1627e6c8748 disable-aes-on-s390x.patch"
diff --git a/testing/monero/disable-aes-on-s390x.patch b/testing/monero/disable-aes-on-s390x.patch
new file mode 100644
index 0000000000..7dfa50ec3b
--- /dev/null
+++ b/testing/monero/disable-aes-on-s390x.patch
@@ -0,0 +1,31 @@
+this patch needs to be changed in next release as git already changed
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3d53e04..7e3dd2c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -90,6 +90,10 @@ if(ARCH_ID STREQUAL "ppc64le")
+ set(PPC64LE 1)
+ endif()
+
++if(ARCH_ID STREQUAL "s390x")
++ set(S390X 1)
++endif()
++
+ if(WIN32 OR ARM)
+ set(OPT_FLAGS_RELEASE "-O2")
+ else()
+@@ -451,10 +455,12 @@ else()
+
+ option(NO_AES "Explicitly disable AES support" ${NO_AES})
+
+- if(NOT NO_AES AND NOT ARM AND NOT PPC64LE)
++ if(NOT NO_AES AND NOT ARM AND NOT PPC64LE AND NOT S390X)
+ message(STATUS "AES support enabled")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -maes")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maes")
++ elseif(S390X)
++ message(STATUS "AES support not available on s390x")
+ elseif(PPC64LE)
+ message(STATUS "AES support not available on ppc64le")
+ elseif(ARM6)