aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monero
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-03-30 05:01:50 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-03-30 22:58:46 +0300
commit62a466fa8c2aa2267fa5d903f5f80e39a3e25d70 (patch)
treed3d7ff1bbdf047ed5f1222a689a0fcca48058a6d /testing/monero
parent86dbf0b83fdaa5a1a0842b680406debcfda8acf8 (diff)
downloadaports-62a466fa8c2aa2267fa5d903f5f80e39a3e25d70.tar.bz2
aports-62a466fa8c2aa2267fa5d903f5f80e39a3e25d70.tar.xz
testing/monero: upgrade to 0.12.0.0
Diffstat (limited to 'testing/monero')
-rw-r--r--testing/monero/APKBUILD12
-rw-r--r--testing/monero/disable-aes-on-s390x.patch18
-rw-r--r--testing/monero/easylogging.patch8
3 files changed, 17 insertions, 21 deletions
diff --git a/testing/monero/APKBUILD b/testing/monero/APKBUILD
index e0dbe7d6f2..22d5733015 100644
--- a/testing/monero/APKBUILD
+++ b/testing/monero/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=monero
-pkgver=0.11.1.0
-pkgrel=2
+pkgver=0.12.0.0
+pkgrel=0
pkgdesc="Secure, private, untraceable cryptocurrency"
url="https://getmonero.org/"
arch="all"
license="BSD"
-makedepends="unbound-dev libressl-dev boost-dev miniupnpc-dev cmake"
+makedepends="unbound-dev libressl-dev boost-dev miniupnpc-dev cmake cppzmq zeromq-dev"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/$pkgname/archive/v$pkgver.tar.gz
easylogging.patch
@@ -28,6 +28,6 @@ package() {
install -m755 -t "${pkgdir}"/usr/bin build/bin/*
}
-sha512sums="bac3520730164afe2ca992c588bd0b51791d986cd8d5ebcaac5bd48185b963e2391c28ee89399d7dd678a5d1f8b41c3ae5724d194a5f62bbcd3e6ad505986573 monero-0.11.1.0.tar.gz
-ff26308bdaf1e0aea9803ece5ec23bebb55d39169e9567c48f4cd4bdceb4fa75cd27fee5bd3d5050273936a3593a29dc2c9d7f5a8dd7a1e0b97a752c48ad4985 easylogging.patch
-32784d187f0c496468fdf5a31071e224a5772d4dab46c053b8d377e5680016d3b7a4fa71fde349e0f200e767b9732492eecd1928b90f3441dff7e1627e6c8748 disable-aes-on-s390x.patch"
+sha512sums="780465569cdd7cf7f38e5e6dc88f420f411e3768ee0e0421cfb2f1ccb48b2fa93261d8f806f51f7fde44f622395c9b90809fea7bb50ad3470a34b8df80bf882e monero-0.12.0.0.tar.gz
+71bb3dd1943dd0850221445e93e07597019691a94bf776950ee2bdb334a670d9ec64fb036f42c5df2846493a0aa4f803c7cb46560fcdb5264cf3d8909d66cef0 easylogging.patch
+b6f2a60822d0ad59b15766d84ec69f99aedac01697097244683f52e9bc24e98f2ba3ddf58d7d26055ff075dcc6894f173099b1213b04f281435ee051ad967e90 disable-aes-on-s390x.patch"
diff --git a/testing/monero/disable-aes-on-s390x.patch b/testing/monero/disable-aes-on-s390x.patch
index 7dfa50ec3b..8581bb7544 100644
--- a/testing/monero/disable-aes-on-s390x.patch
+++ b/testing/monero/disable-aes-on-s390x.patch
@@ -1,10 +1,6 @@
-this patch needs to be changed in next release as git already changed
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3d53e04..7e3dd2c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -90,6 +90,10 @@ if(ARCH_ID STREQUAL "ppc64le")
+@@ -139,6 +139,10 @@
set(PPC64LE 1)
endif()
@@ -15,12 +11,12 @@ index 3d53e04..7e3dd2c 100644
if(WIN32 OR ARM)
set(OPT_FLAGS_RELEASE "-O2")
else()
-@@ -451,10 +455,12 @@ else()
-
- option(NO_AES "Explicitly disable AES support" ${NO_AES})
-
-- if(NOT NO_AES AND NOT ARM AND NOT PPC64LE)
-+ if(NOT NO_AES AND NOT ARM AND NOT PPC64LE AND NOT S390X)
+@@ -592,10 +596,12 @@
+ message(STATUS "AES support explicitly disabled")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNO_AES")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DNO_AES")
+- elseif(NOT ARM AND NOT PPC64LE)
++ elseif(NOT ARM AND NOT PPC64LE AND NOT S390X)
message(STATUS "AES support enabled")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -maes")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maes")
diff --git a/testing/monero/easylogging.patch b/testing/monero/easylogging.patch
index 6cea439a58..27082046be 100644
--- a/testing/monero/easylogging.patch
+++ b/testing/monero/easylogging.patch
@@ -1,11 +1,11 @@
--- a/external/easylogging++/easylogging++.h
+++ b/external/easylogging++/easylogging++.h
-@@ -195,7 +195,7 @@
+@@ -200,7 +200,7 @@
# define ELPP_INTERNAL_INFO(lvl, msg)
#endif // (defined(ELPP_DEBUG_INFO))
#if (defined(ELPP_FEATURE_ALL)) || (defined(ELPP_FEATURE_CRASH_LOG))
--# if (ELPP_COMPILER_GCC && !ELPP_MINGW)
-+# if (__has_include(<execinfo.h>) && ELPP_COMPILER_GCC && !ELPP_MINGW)
+-# if (ELPP_COMPILER_GCC && !ELPP_MINGW && !ELPP_OS_OPENBSD)
++# if (__has_include(<execinfo.h>) && ELPP_COMPILER_GCC && !ELPP_MINGW && !ELPP_OS_OPENBSD)
# define ELPP_STACKTRACE 1
# else
- # define ELPP_STACKTRACE 0
+ # define ELPP_STACKTRACE 0