aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mongo-cxx-driver
diff options
context:
space:
mode:
authorRuss <russ@rw.id.au>2019-07-29 15:31:14 +1000
committerLeo <thinkabit.ukim@gmail.com>2019-07-29 03:36:03 -0300
commit2abaecfa48da4d544520a9837c0f6780c917923b (patch)
treeca9899916af41eb08bb4bc1c1f3e1d38d40ef3ea /testing/mongo-cxx-driver
parent01694a410638e63683aafe0601e4e8903de9f050 (diff)
downloadaports-2abaecfa48da4d544520a9837c0f6780c917923b.tar.bz2
aports-2abaecfa48da4d544520a9837c0f6780c917923b.tar.xz
testing/mongo-cxx-driver: fix depends_dev
ref https://gitlab.alpinelinux.org/alpine/abuild/issues/9975
Diffstat (limited to 'testing/mongo-cxx-driver')
-rw-r--r--testing/mongo-cxx-driver/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/mongo-cxx-driver/APKBUILD b/testing/mongo-cxx-driver/APKBUILD
index e840cb2e2d..b8d33a9109 100644
--- a/testing/mongo-cxx-driver/APKBUILD
+++ b/testing/mongo-cxx-driver/APKBUILD
@@ -3,14 +3,13 @@
pkgname="mongo-cxx-driver"
pkgver="3.4.0"
_commit="131fa1a67acd45c0eebcbdcfee42b212af8d2e80" # master compiles with GCC8.3/CXX17
-pkgrel=0
+pkgrel=1
pkgdesc="C++ driver for MongoDB"
url="http://mongocxx.org/"
arch="all"
license="Apache-2.0"
makedepends="cmake mongo-c-driver-dev libbson-dev openssl-dev python3 snappy-dev"
subpackages="$pkgname-dev:_dev libbsoncxx libbsoncxx-dev"
-depends_dev="libbson-dev"
source="mongo-cxx-driver-$pkgver.tar.gz::https://github.com/mongodb/mongo-cxx-driver/archive/$_commit.tar.gz
01-dont-build-mongo-tests.patch"
builddir="$srcdir/mongo-cxx-driver-$_commit"
@@ -58,6 +57,11 @@ libbsoncxx() {
}
_dev() {
+ # This should be removed once abuild knows how to search for pkg-config
+ # files that are in another subpackage that is also being created alongside
+ # this one.
+ depends_dev="libbsoncxx-dev"
+
default_dev
# libbsoncxx pkg-config files