aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mono
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-07 07:36:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-07 07:47:13 +0000
commit7e7d89c69f1a98de61b1a317f76d39996845e563 (patch)
treeb631e511b13fa32787087b78c6af1014f0f0afd1 /testing/mono
parent4734e1fa08aae81b9741d65766bb295b3be157de (diff)
downloadaports-7e7d89c69f1a98de61b1a317f76d39996845e563.tar.bz2
aports-7e7d89c69f1a98de61b1a317f76d39996845e563.tar.xz
testing/mono: upgrade to 4.0.4.1
Diffstat (limited to 'testing/mono')
-rw-r--r--testing/mono/APKBUILD24
-rw-r--r--testing/mono/assume-UTC-if-no-TZ-set.patch31
2 files changed, 46 insertions, 9 deletions
diff --git a/testing/mono/APKBUILD b/testing/mono/APKBUILD
index 70587f111c..41fbcc95cf 100644
--- a/testing/mono/APKBUILD
+++ b/testing/mono/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=mono
-pkgver=4.0.1
-pkgrel=1
+pkgver=4.0.4.1
+pkgrel=0
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
url="http://www.mono-project.com/"
arch="all"
@@ -12,9 +12,11 @@ depends_dev="zlib-dev libgdiplus-dev"
makedepends="$depends_dev python linux-headers paxmark autoconf automake libtool"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2"
+source="http://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2
+ assume-UTC-if-no-TZ-set.patch
+ "
-_builddir="$srcdir"/mono-${pkgver%%_*}
+_builddir="$srcdir"/mono-${pkgver%.*}
prepare() {
local i
@@ -52,11 +54,15 @@ build() {
package() {
cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install || return 1
# mark all bins
- paxmark -mr "$pkgdir"/usr/bin/*
+ scanelf --nobanner "$pkgdir"/usr/bin/* | awk '{print $2}' \
+ | xargs paxmark -mr
}
-md5sums="426065ce1aba25fd3e776ea736c5f430 mono-4.0.1.tar.bz2"
-sha256sums="ff1f15f3b8d43c6a2818c00fabe377b2d8408ad14acd9d507658b4cae00f5bce mono-4.0.1.tar.bz2"
-sha512sums="b021ef977a1044718ea16b5f2ed50c2a75a469b1f359ae397acb830ad2e9406bb83129856d4975c39146ec464fe4e0a665b9e80a473ccfeb835eb9198717763b mono-4.0.1.tar.bz2"
+md5sums="f598b60a664dfebb1a5eef3e66a9a178 mono-4.0.4.1.tar.bz2
+4a762b5e095baf78705d39fc2918fca7 assume-UTC-if-no-TZ-set.patch"
+sha256sums="ed11ed20ce5930c775af02bd41c43658bc9320f0bfd592fbb9895d95104dbcf9 mono-4.0.4.1.tar.bz2
+1be0b3ecf2949d79298f5b449b710a78610933f165fe2c10c37b84cf26383f56 assume-UTC-if-no-TZ-set.patch"
+sha512sums="2f299e97dd3014c9d221677e73e5134a0c0a5b27e479fb60aabc2b3eddedf07f525f3a74194ccbfdf8efe63d7ea72850f8ee64d6f15f51bccd5db0df6c1b3722 mono-4.0.4.1.tar.bz2
+aa294f81fb7f5815ef37ad191e41766836e95bf3e0ce2592e6da88cbb6c2e408b2e4cbd9c81d39f3e575ba3f1590dba5abe26d8b465b56d3f25e228dbb0ddf70 assume-UTC-if-no-TZ-set.patch"
diff --git a/testing/mono/assume-UTC-if-no-TZ-set.patch b/testing/mono/assume-UTC-if-no-TZ-set.patch
new file mode 100644
index 0000000000..ee89a3ad98
--- /dev/null
+++ b/testing/mono/assume-UTC-if-no-TZ-set.patch
@@ -0,0 +1,31 @@
+From cf4e7339e31d19e6934d7b8130f82697212ea39e Mon Sep 17 00:00:00 2001
+From: Marcin Cieslak <saper@saper.info>
+Date: Sun, 7 Jun 2015 20:14:47 +0000
+Subject: [PATCH] [corlib] Assume UTC if no $TZ set. Fixes #30360
+
+Don't throw System.TimeZoneNotFoundException
+if no $TZ is set and there is no /etc/localtime
+or similar file.
+---
+ mcs/class/corlib/System/TimeZoneInfo.cs | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/mcs/class/corlib/System/TimeZoneInfo.cs b/mcs/class/corlib/System/TimeZoneInfo.cs
+index 717bfa7..6babee8 100644
+--- a/mcs/class/corlib/System/TimeZoneInfo.cs
++++ b/mcs/class/corlib/System/TimeZoneInfo.cs
+@@ -116,11 +116,11 @@ static TimeZoneInfo CreateLocal ()
+
+ try {
+ return FindSystemTimeZoneByFileName ("Local", "/etc/localtime");
+- } catch {
++ } catch (TimeZoneNotFoundException) {
+ try {
+ return FindSystemTimeZoneByFileName ("Local", Path.Combine (TimeZoneDirectory, "localtime"));
+- } catch {
+- return null;
++ } catch (TimeZoneNotFoundException) {
++ return Utc;
+ }
+ }
+ }