aboutsummaryrefslogtreecommitdiffstats
path: root/testing/motion
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2019-02-18 19:11:39 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-02-19 11:53:26 +0000
commitb4387947d21e4fba56b41d59aaffdaf46168adfd (patch)
tree1563ec3cf092e41ff4099782ec9e6d977a3cc827 /testing/motion
parent232c047147f69ee0210fe4d56136eaf151b23fb9 (diff)
downloadaports-b4387947d21e4fba56b41d59aaffdaf46168adfd.tar.bz2
aports-b4387947d21e4fba56b41d59aaffdaf46168adfd.tar.xz
testing/motion: upgrade to 4.2.2
Diffstat (limited to 'testing/motion')
-rw-r--r--testing/motion/APKBUILD18
-rw-r--r--testing/motion/ffmpeg4.patch43
-rw-r--r--testing/motion/motion-dist.conf.in.patch73
3 files changed, 8 insertions, 126 deletions
diff --git a/testing/motion/APKBUILD b/testing/motion/APKBUILD
index f4b3036c15..70f6781ab9 100644
--- a/testing/motion/APKBUILD
+++ b/testing/motion/APKBUILD
@@ -3,8 +3,8 @@
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=motion
-pkgver=4.1.1
-pkgrel=1
+pkgver=4.2.2
+pkgrel=0
pkgdesc="Detect if a significant part of the picture has changed (e.g. from a webcam)."
url="https://motion-project.github.io"
arch="all"
@@ -14,15 +14,15 @@ pkgusers="motion"
pkggroups="motion"
depends="jpeg v4l-utils ffmpeg"
depends_dev=""
-makedepends="$depends_dev autoconf automake bash jpeg-dev v4l-utils-dev linux-headers ffmpeg-dev"
+makedepends="$depends_dev autoconf automake bash jpeg-dev v4l-utils-dev linux-headers
+ ffmpeg-dev libmicrohttpd-dev libwebp-dev
+ "
install="$pkgname.pre-install"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-openrc $pkgname-lang"
# ffmpeg4.patch courtesy of Arch Linux
source="$pkgname-$pkgver.tar.gz::https://github.com/Motion-Project/$pkgname/archive/release-$pkgver.tar.gz
motion.confd
motion.initd
- motion-dist.conf.in.patch
- ffmpeg4.patch
"
builddir="$srcdir"/$pkgname-release-$pkgver
@@ -54,8 +54,6 @@ package() {
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="3b08d464f9243ccfc4b53b16cfc2001d1e0d206bf0295d55d8914914bc14ad0248ce5ac622cb7eb89ed32e1913a9a10add1b56497c4094ba876f7f85d6ad4143 motion-4.1.1.tar.gz
+sha512sums="d6a1df1f7ddf8e3dc8fe3f7a1639de1ea67e63323d928c5c8b3bd34ee4edcb034c6723c3cc5d05ff1dd95802cd8efb4362cfcb68064ec5884272efa8f57daa20 motion-4.2.2.tar.gz
8a67b5b0360924e58ba3136a737ce73bb43201a49b2b6e2c632426561b830f6ab55cbbeaa89be7f1683aa8fd322b4f31b9f560e67a93eaceb964c9f56ceef363 motion.confd
-be30f19595dba27f2d0ca8133c93e134161781935a152bd1701e581410039e37742acd11987c38e6e64f495b1fd2b0a74a8c61ae0e6e211a475fca7994172501 motion.initd
-c27d7ded3ed7a56101791bca86eb083450f5b8a1f431b3f7ee8538f682ac5f5d4b50104d9d61f40be964f1f1975a114313ba3d30d7357035dc25ebe925db6a89 motion-dist.conf.in.patch
-808a43fe51dd2d9436320fa3ba3ac3b3f87c829b276f175b52c77313acaa647dda43cd2acc0f9c6a3106ca0dec568ee12c6db7ad89cc49f501e34cd223bfb65e ffmpeg4.patch"
+be30f19595dba27f2d0ca8133c93e134161781935a152bd1701e581410039e37742acd11987c38e6e64f495b1fd2b0a74a8c61ae0e6e211a475fca7994172501 motion.initd"
diff --git a/testing/motion/ffmpeg4.patch b/testing/motion/ffmpeg4.patch
deleted file mode 100644
index 3ac4c7967b..0000000000
--- a/testing/motion/ffmpeg4.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff --git a/ffmpeg.c b/ffmpeg.c
-index 1e6cdf6..4299ba3 100644
---- a/ffmpeg.c
-+++ b/ffmpeg.c
-@@ -67,6 +67,19 @@
-
- #endif
-
-+/*********************************************/
-+#if (LIBAVCODEC_VERSION_MAJOR >= 57)
-+
-+#define MY_CODEC_FLAG_GLOBAL_HEADER AV_CODEC_FLAG_GLOBAL_HEADER
-+#define MY_CODEC_FLAG_QSCALE AV_CODEC_FLAG_QSCALE
-+
-+#else
-+
-+#define MY_CODEC_FLAG_GLOBAL_HEADER CODEC_FLAG_GLOBAL_HEADER
-+#define MY_CODEC_FLAG_QSCALE CODEC_FLAG_QSCALE
-+
-+#endif
-+
- /*********************************************/
- AVFrame *my_frame_alloc(void){
- AVFrame *pic;
-@@ -548,7 +561,7 @@ static int ffmpeg_set_quality(struct ffmpeg *ffmpeg){
- /* The selection of 8000 is a subjective number based upon viewing output files */
- if (ffmpeg->vbr > 0){
- ffmpeg->vbr =(int)(((100-ffmpeg->vbr)*(100-ffmpeg->vbr)*(100-ffmpeg->vbr) * 8000) / 1000000) + 1;
-- ffmpeg->ctx_codec->flags |= CODEC_FLAG_QSCALE;
-+ ffmpeg->ctx_codec->flags |= MY_CODEC_FLAG_QSCALE;
- ffmpeg->ctx_codec->global_quality=ffmpeg->vbr;
- }
- }
-@@ -673,7 +686,7 @@ static int ffmpeg_set_codec(struct ffmpeg *ffmpeg){
- ffmpeg->ctx_codec->strict_std_compliance = -2;
- ffmpeg->ctx_codec->level = 3;
- }
-- ffmpeg->ctx_codec->flags |= CODEC_FLAG_GLOBAL_HEADER;
-+ ffmpeg->ctx_codec->flags |= MY_CODEC_FLAG_GLOBAL_HEADER;
-
- retcd = ffmpeg_set_quality(ffmpeg);
- if (retcd < 0){
-
diff --git a/testing/motion/motion-dist.conf.in.patch b/testing/motion/motion-dist.conf.in.patch
deleted file mode 100644
index a707436e68..0000000000
--- a/testing/motion/motion-dist.conf.in.patch
+++ /dev/null
@@ -1,73 +0,0 @@
---- a/motion-dist.conf.in
-+++ b/motion-dist.conf.in
-@@ -633,70 +633,6 @@
- # NOTE: If motion doesn't properly detect a lost camera, it also won't know it found one.
- ; on_camera_found value
-
--#####################################################################
--# Common Options for database features.
--# Options require database options to be active also.
--#####################################################################
--
--# Log to the database when creating motion triggered picture file (default: on)
--; sql_log_picture on
--
--# Log to the database when creating a snapshot image file (default: on)
--; sql_log_snapshot on
--
--# Log to the database when creating motion triggered movie file (default: off)
--; sql_log_movie off
--
--# Log to the database when creating timelapse movies file (default: off)
--; sql_log_timelapse off
--
--# SQL query string that is sent to the database
--# Use same conversion specifiers has for text features
--# Additional special conversion specifiers are
--# %n = the number representing the file_type
--# %f = filename with full path
--# Default value:
--# Create tables :
--##
--# Mysql
--# CREATE TABLE security (camera int, filename char(80) not null, frame int, file_type int, time_stamp timestamp(14), event_time_stamp timestamp(14));
--#
--# Postgresql
--# CREATE TABLE security (camera int, filename char(80) not null, frame int, file_type int, time_stamp timestamp without time zone, event_time_stamp timestamp without time zone);
--#
--# insert into security(camera, filename, frame, file_type, time_stamp, text_event) values('%t', '%f', '%q', '%n', '%Y-%m-%d %T', '%C')
--; sql_query insert into security(camera, filename, frame, file_type, time_stamp, event_time_stamp) values('%t', '%f', '%q', '%n', '%Y-%m-%d %T', '%C')
--
--
--############################################################
--# Database Options
--############################################################
--
--# database type : mysql, postgresql, sqlite3 (default : not defined)
--; database_type value
--
--# database to log to (default: not defined)
--# for sqlite3, the full path and name for the database.
--; database_dbname value
--
--# The host on which the database is located (default: localhost)
--; database_host value
--
--# User account name for database (default: not defined)
--; database_user value
--
--# User password for database (default: not defined)
--; database_password value
--
--# Port on which the database is located
--# mysql 3306 , postgresql 5432 (default: not defined)
--; database_port value
--
--# Database wait time in milliseconds for locked database to
--# be unlocked before returning database locked error (default 0)
--; database_busy_timeout 0
--
--
-
- ############################################################
- # Video Loopback Device (vloopback project)