aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ms-sys
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-16 14:38:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 14:41:24 +0000
commit6272dd28c07dc0575ef5a77eb2256e13c0d42a2c (patch)
tree2c84278a34b9e63ab623dff9f841381c737a8376 /testing/ms-sys
parent6c55fa97d8e5cf7bb1c5e25a17621859cf54641c (diff)
downloadaports-6272dd28c07dc0575ef5a77eb2256e13c0d42a2c.tar.bz2
aports-6272dd28c07dc0575ef5a77eb2256e13c0d42a2c.tar.xz
testing/ms-sys: build without gettext
its not worth the extra bloat only to have swedish translation available
Diffstat (limited to 'testing/ms-sys')
-rw-r--r--testing/ms-sys/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/testing/ms-sys/APKBUILD b/testing/ms-sys/APKBUILD
index 18b9a22fe8..118b7aca6f 100644
--- a/testing/ms-sys/APKBUILD
+++ b/testing/ms-sys/APKBUILD
@@ -2,31 +2,29 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=ms-sys
pkgver=2.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="A tool for creating Microsoft compatible boot records"
url="http://ms-sys.sourceforge.net/"
arch="all"
license="GPL2+"
depends=""
depends_dev=""
-makedepends="gettext"
install=""
-subpackages="$pkgname-doc $pkgname-lang"
+subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/ms-sys/ms-sys-$pkgver.tar.gz"
_builddir="$srcdir"/ms-sys-$pkgver
build() {
cd "$_builddir"
- make LDFLAGS="-lintl" || return 1
+ make bin/ms-sys || return 1
}
package() {
cd "$_builddir"
- make \
- PREFIX="/usr" \
- MANDIR="/usr/share/man" \
- DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
+ install -Dm755 bin/ms-sys "$pkgdir"/usr/bin/ms-sys || return 1
+ install -Dm644 man/ms-sys.1 "$pkgdir"/usr/share/man/man1/ms-sys.1 \
+ || return 1
+
}
md5sums="659fb46f1b014abe64ae7d635c5bc1f8 ms-sys-2.2.1.tar.gz"