aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mycli/APKBUILD
diff options
context:
space:
mode:
authorThomas Boerger <thomas@webhippie.de>2016-07-06 10:06:43 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-07-06 18:39:37 +0200
commita23875f327ce2d1927a8cafe4c7b0ec75907c22d (patch)
tree94a1693fb6fa76d61a7be6391d1e8b0e8151069d /testing/mycli/APKBUILD
parenteb153d4781a2adc93835e559bbb9742cad8ba36d (diff)
downloadaports-a23875f327ce2d1927a8cafe4c7b0ec75907c22d.tar.bz2
aports-a23875f327ce2d1927a8cafe4c7b0ec75907c22d.tar.xz
testing/mycli: new aport
http://mycli.net MySQL CLI with autocompletion and syntax highlighting
Diffstat (limited to 'testing/mycli/APKBUILD')
-rw-r--r--testing/mycli/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/mycli/APKBUILD b/testing/mycli/APKBUILD
new file mode 100644
index 0000000000..0d89c1942a
--- /dev/null
+++ b/testing/mycli/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=mycli
+pkgver=1.7.1
+pkgrel=0
+pkgdesc="MySQL CLI with autocompletion and syntax highlighting"
+url="http://mycli.net"
+arch="noarch"
+license="BSD"
+depends="python
+ py-click
+ py-pygments
+ py-prompt_toolkit<1.1.0
+ py-pymysql
+ py-sqlparse
+ py-configobj>=5.0.6
+ py-crypto"
+makedepends="python-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="016facc75d562ce41e4dd3242f918c6a mycli-1.7.1.tar.gz"
+sha256sums="56ee9a06bcfa3a64ee1ed555bddc69d9e4b5d31dee98bde6cc2712c5c3f5422d mycli-1.7.1.tar.gz"
+sha512sums="343b31630f509e9c175014c4534ea7ffc56fee08fbfe5376430e6f85630617b66063bf4224ef93bd920892af2d83377013f467525954ebcd0e253e6b32272d88 mycli-1.7.1.tar.gz"