aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mycroft-skill-query
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-01 12:25:16 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-09 20:05:22 +0000
commitb11275f777c405ee43302ff0f62509cfa32c16ec (patch)
treef48d597c9b0365e9862e59783688c4e43dfeba29 /testing/mycroft-skill-query
parentb19ec2a2dfc86c5c23a1d8486737964b778fb081 (diff)
downloadaports-b11275f777c405ee43302ff0f62509cfa32c16ec.tar.bz2
aports-b11275f777c405ee43302ff0f62509cfa32c16ec.tar.xz
testing/mycroft-skill-query: new aport
Diffstat (limited to 'testing/mycroft-skill-query')
-rw-r--r--testing/mycroft-skill-query/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/mycroft-skill-query/APKBUILD b/testing/mycroft-skill-query/APKBUILD
new file mode 100644
index 0000000000..d17d59f8ab
--- /dev/null
+++ b/testing/mycroft-skill-query/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=mycroft-skill-query
+pkgver=20.02_git20200409
+pkgrel=0
+_commit="8122f664ea5faf4e8dc07208188f1fbfcbce139b"
+pkgdesc="Skill Negotiating for the best source for an answer via Common QA "
+url="https://mycroft.ai/skills"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+source="https://github.com/mycroftai/skill-query/archive/$_commit/skills-query-$_commit.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/skill-query-$_commit"
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/mycroft/skills/fallback-query.mycroftai
+ cp -r ./* "$pkgdir"/usr/share/mycroft/skills/fallback-query.mycroftai/
+}
+
+sha512sums="be66a3593bb9c56baf7eaf91564421da08d058aa1d711dacf32991012671c0f47dcac6b760c98ba98708ca6bd6986933a6b500062ac7f85112ab4253629e575c skills-query-8122f664ea5faf4e8dc07208188f1fbfcbce139b.tar.gz"