aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ndctl
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-23 00:31:48 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-23 00:33:14 +0200
commitf7c50abee5e311f6cca5756f3cc09edc7a206628 (patch)
treef1300bf71a4f2ac33beceecbda664a01670dcfc7 /testing/ndctl
parentd335c5505a9b46a0cdb5d478ecba5441897cc538 (diff)
downloadaports-f7c50abee5e311f6cca5756f3cc09edc7a206628.tar.bz2
aports-f7c50abee5e311f6cca5756f3cc09edc7a206628.tar.xz
testing/ndctl: run ./autogen.sh in prepare()
Diffstat (limited to 'testing/ndctl')
-rw-r--r--testing/ndctl/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/testing/ndctl/APKBUILD b/testing/ndctl/APKBUILD
index 6e8a3dc1dd..ca49a40a82 100644
--- a/testing/ndctl/APKBUILD
+++ b/testing/ndctl/APKBUILD
@@ -7,20 +7,27 @@ url="https://github.com/pmem/ndctl"
arch="all"
license="GPL"
depends="libuuid json-c kmod"
-makedepends="autoconf automake libtool asciidoc xmlto kmod-dev eudev-dev util-linux-dev json-c-dev linux-headers"
+makedepends="autoconf automake libtool asciidoc xmlto kmod-dev
+ eudev-dev util-linux-dev json-c-dev linux-headers"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/pmem/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
-builddir="$srcdir"/ndctl-$pkgver
+prepare() {
+ default_prepare
+ cd "$builddir"
+ ./autogen.sh
+}
build() {
cd "$builddir"
- ./autogen.sh
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --mandir=/usr/share/man
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
make
}