aboutsummaryrefslogtreecommitdiffstats
path: root/testing/next/APKBUILD
diff options
context:
space:
mode:
authorWill Sinatra <wpsinatra@gmail.com>2019-09-30 11:22:32 -0500
committerRasmus Thomsen <oss@cogitri.dev>2019-10-06 11:31:04 +0200
commit75e6b4723d409a3fbeb1fab09a4578a7910bed44 (patch)
treee8c90af74c6a5da366633ed960231d41fa092d2e /testing/next/APKBUILD
parent638cf1c453b6bcc8424100575a59d7f892be2764 (diff)
downloadaports-75e6b4723d409a3fbeb1fab09a4578a7910bed44.tar.bz2
aports-75e6b4723d409a3fbeb1fab09a4578a7910bed44.tar.xz
testing/next: new aport
New aport for Atlas Engineering's NEXT browser
Diffstat (limited to 'testing/next/APKBUILD')
-rw-r--r--testing/next/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/next/APKBUILD b/testing/next/APKBUILD
new file mode 100644
index 0000000000..bacbf975bf
--- /dev/null
+++ b/testing/next/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
+# Contributor: Will Sinatra <wpsinatra@gmail.com>
+# Contributor: Benjamin Buccianti <bebuccianti@gmail.com>
+pkgname=next
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="Atlas Engineer Next Browser"
+url="https://next.atlas.engineer"
+arch="x86_64" #SBCL currently only built for x86_64, to be expanded once compatibility is met.
+license="BSD-3-Clause"
+source=next.zip::"https://github.com/atlas-engineer/next/archive/$pkgver.zip"
+makedepends="git sbcl webkit2gtk-dev"
+depends="webkit2gtk glib-networking gsettings-desktop-schemas libfixposix libfixposix-dev gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad gst-plugins-ugly libffi libffi-dev"
+options="!check !strip" #No testsuite exists; Stripping the package causes the
+# package to build, but the next browser is unfunctional, dropping to an SBCL repl
+# instead of properly running.
+
+
+build() {
+ make all
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+sha512sums="07bc3b47a4ebb3857d7ada4c8dc56d35f7c84460d108467a580b6d42a9da273ffafd73b2beb8274f94788554444132beb605b383fd9e3d6d4ff6cacc1e870da9 next.zip"