aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nitro
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-08-29 13:26:22 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 13:26:22 +0300
commitc31e3dc4523bc0b1a15830125372475d7395ce02 (patch)
treee429d749b843b0eebbf4da20f25f662b1165703b /testing/nitro
parent911268569afcf0b6c7692892bb1ee439dfd4a7be (diff)
downloadaports-c31e3dc4523bc0b1a15830125372475d7395ce02.tar.bz2
aports-c31e3dc4523bc0b1a15830125372475d7395ce02.tar.xz
testing/nitro: include limits.h for PATH_MAX
Diffstat (limited to 'testing/nitro')
-rw-r--r--testing/nitro/APKBUILD7
-rw-r--r--testing/nitro/fix-path-max.patch10
2 files changed, 15 insertions, 2 deletions
diff --git a/testing/nitro/APKBUILD b/testing/nitro/APKBUILD
index 5a19911eab..cdb09269e8 100644
--- a/testing/nitro/APKBUILD
+++ b/testing/nitro/APKBUILD
@@ -12,7 +12,9 @@ depends=""
makedepends="cmake linux-headers"
install=""
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hobu/$pkgname/archive/$_pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hobu/$pkgname/archive/$_pkgver.tar.gz
+ fix-path-max.patch
+ "
builddir="$srcdir/$pkgname-$_pkgver"
options="!check"
@@ -32,4 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="825a0561393b231cfd1de057401b4051214a54b50fc5f04a6125cb6a6fc160863a6224145daa621582c164a1a39aebad26ca818d2cedc09fbfda2bcab663a0ed nitro-2.7.tar.gz"
+sha512sums="825a0561393b231cfd1de057401b4051214a54b50fc5f04a6125cb6a6fc160863a6224145daa621582c164a1a39aebad26ca818d2cedc09fbfda2bcab663a0ed nitro-2.7.tar.gz
+4bf97526c39ae9a7c402d42451770b5b1383e44b426b49685a8d66ce5b0dd178f47e0865349b9c4b953af4b94616b2493d732c4562e6be10ba96b40bd1332052 fix-path-max.patch"
diff --git a/testing/nitro/fix-path-max.patch b/testing/nitro/fix-path-max.patch
new file mode 100644
index 0000000000..4a3c575527
--- /dev/null
+++ b/testing/nitro/fix-path-max.patch
@@ -0,0 +1,10 @@
+--- nitro-2.7dev-1/c++/sys/source/OSUnix.cpp.orig 2017-08-29 13:22:41.833028289 +0300
++++ nitro-2.7dev-1/c++/sys/source/OSUnix.cpp 2017-08-29 13:22:59.726615275 +0300
+@@ -25,6 +25,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <limits.h>
+
+ #include "sys/OSUnix.h"
+ #include "sys/File.h"