aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nlohmann-json
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-08-18 16:26:35 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-08-18 17:11:32 +0200
commitf930960501f6b6b7c748df0c7558de47b5fb03d5 (patch)
tree4d045780df5c81c91e793e5735bf17e41fe1c9f1 /testing/nlohmann-json
parent4cf7aa27fce588eddec1762294c199c14b510c67 (diff)
downloadaports-f930960501f6b6b7c748df0c7558de47b5fb03d5.tar.bz2
aports-f930960501f6b6b7c748df0c7558de47b5fb03d5.tar.xz
testing/nlohmann-json: upgrade to 3.7.0
Diffstat (limited to 'testing/nlohmann-json')
-rw-r--r--testing/nlohmann-json/APKBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/testing/nlohmann-json/APKBUILD b/testing/nlohmann-json/APKBUILD
index 01733cd9f6..b1dd0c6e23 100644
--- a/testing/nlohmann-json/APKBUILD
+++ b/testing/nlohmann-json/APKBUILD
@@ -1,34 +1,35 @@
# Contributor: Nick Black <dankamongmen@gmail.com>
-# This is a headers-only implementaiton; there are no libraries.
+# Maintainer:
pkgname=nlohmann-json
-pkgver=3.6.1
-pkgrel=1
+pkgver=3.7.0
+pkgrel=0
pkgdesc="JSON for Modern C++"
url="https://github.com/nlohmann/json"
arch="noarch"
license="MIT"
-makedepends="doxygen"
-subpackages="nlohmann-json-doc"
+makedepends="cmake doxygen graphviz"
+subpackages="$pkgname-dev $pkgname-doc"
source="nlohmann-json-$pkgver.tar.gz::https://github.com/nlohmann/json/archive/v$pkgver.tar.gz"
builddir="$srcdir/json-$pkgver"
build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
make -C doc
}
check() {
- if [ "$CARCH" != "s390x" ]; then make check-fast; fi
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- mkdir -p "$pkgdir/usr/include"
- mv include/nlohmann "$pkgdir/usr/include"
-}
+ DESTDIR="$pkgdir" make install
-doc() {
- cd "$builddir"
- mkdir -p "$subpkgdir/usr/share/doc/nlohmann-json"
- mv README.md doc/html "$subpkgdir/usr/share/doc/nlohmann-json"
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ mv doc/html "$pkgdir"/usr/share/doc/$pkgname/
}
-sha512sums="e0565ccdee34e89a6836a97f039c04a0bac445b44f6f323918ea424b34e4577688a4f4f72d5ef1ec0b53d159bfe87e8e9c97b70ef98231ea463f59f05e16eb2a nlohmann-json-3.6.1.tar.gz"
+sha512sums="35510a0ee59d847ff9fcd4f4026ef936abb89675884fdd2db808f8349a55073206f764cd4f797deb1b6493ea0e04889505f49483e5b88798011dd5db87e7c87d nlohmann-json-3.7.0.tar.gz"