aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nqp
diff options
context:
space:
mode:
authorCurt Tilmes <curt@tilmes.org>2018-02-20 09:21:05 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-27 21:16:07 +0000
commit0ffa38bc9e7fee95689002f2cf9f2c12d40c5a41 (patch)
tree4e996a6965bea2f94b2f2492b205eeb990ce5484 /testing/nqp
parentd682c483a163835e640ce8331dde2e449a407daf (diff)
downloadaports-0ffa38bc9e7fee95689002f2cf9f2c12d40c5a41.tar.bz2
aports-0ffa38bc9e7fee95689002f2cf9f2c12d40c5a41.tar.xz
testing/nqp: new aport
https://github.com/perl6/nqp Not Quite Perl
Diffstat (limited to 'testing/nqp')
-rw-r--r--testing/nqp/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/nqp/APKBUILD b/testing/nqp/APKBUILD
new file mode 100644
index 0000000000..dd7763a549
--- /dev/null
+++ b/testing/nqp/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Curt Tilmes <Curt.Tilmes@nasa.gov>
+# Maintainer: Curt Tilmes <Curt.Tilmes@nasa.gov>
+pkgname=nqp
+pkgver=2018.02
+pkgrel=0
+pkgdesc="Not Quite Perl"
+url="https://github.com/perl6/nqp"
+arch="all"
+options="!archcheck" # Arch dependencies are embedded
+license="Artistic-2.0"
+depends="moarvm"
+makedepends="perl-utils gcc musl-dev make moarvm-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-examples"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/perl6/nqp/archive/${pkgver}.tar.gz"
+builddir="$srcdir"/"$pkgname"-"$pkgver"
+
+build() {
+ cd "$builddir"
+ perl Configure.pl --prefix=/usr --backends=moar
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+doc() {
+ cd "$builddir"
+ mkdir -p "$subpkgdir"/usr/share/doc/"$pkgname"
+ for file in CREDITS LICENSE README.pod VERSION docs; do
+ cp -r $file "$subpkgdir"/usr/share/doc/"$pkgname"
+ done
+}
+
+examples() {
+ cd "$builddir"
+ mkdir -p "$subpkgdir"/usr/share/doc/"$pkgname"
+ for file in examples; do
+ cp -r $file "$subpkgdir"/usr/share/doc/"$pkgname"
+ done
+}
+
+sha512sums="6e12bd191522c1acc4195dfb98982b6ddc54decb5a40b9995ffc16fb0988bb96fb27057e77dedcbf2dfbc1b222a4fe92df19cb585ed53bb021b9d07b20275efc nqp-2018.02.tar.gz"