aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nsq/APKBUILD
diff options
context:
space:
mode:
authorMichael Pirogov <vbnet.ru@gmail.com>2019-12-24 19:32:50 +0300
committerLeo <thinkabit.ukim@gmail.com>2019-12-25 12:48:22 +0100
commit9fa23921c38df4a5d2dc6da269c3b032e6ba83d3 (patch)
tree205056cb582cd8a2a83e923b5fa630530123446a /testing/nsq/APKBUILD
parent0e5f8a698cff67091724ba162b5c36b7a124c4bc (diff)
downloadaports-9fa23921c38df4a5d2dc6da269c3b032e6ba83d3.tar.bz2
aports-9fa23921c38df4a5d2dc6da269c3b032e6ba83d3.tar.xz
testing/nsq: new aport
Diffstat (limited to 'testing/nsq/APKBUILD')
-rw-r--r--testing/nsq/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/nsq/APKBUILD b/testing/nsq/APKBUILD
new file mode 100644
index 0000000000..1e01271d01
--- /dev/null
+++ b/testing/nsq/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
+# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
+pkgname=nsq
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="A realtime distributed messaging platform"
+url="https://nsq.io/"
+arch="all"
+license="MIT"
+depends="go"
+makedepends="dep"
+options="chmod-clean"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nsqio/nsq/archive/v$pkgver.tar.gz
+ glibc-test.patch"
+builddir="$srcdir/go/src/github.com/nsqio/$pkgname"
+
+prepare() {
+ mkdir -p ${builddir%/*}
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+ export GOPATH="$srcdir/go"
+ default_prepare
+ cd "$builddir" # just created
+ dep ensure
+}
+
+build() {
+ export GOPATH="$srcdir/go"
+ make
+}
+
+check() {
+ ./test.sh
+}
+
+package() {
+ cd build
+ for file in *; do
+ install -sD -m 755 "$file" "$pkgdir"/usr/bin/"$file"
+ done
+}
+
+
+sha512sums="01ef18775a3ee6688fed2c7b85f35099d6b01e9a2f10813b3baa94a6c5a2974abf70ee8d2c6d5aebb6952825ab0a2f986838d3dc35e7b5e06bef3ffa8c0e7c15 nsq-1.2.0.tar.gz
+e0fa26f0a7b412dc4b3e56cb1d557183d86e751862b86f9192fca153232e856713c2cf76f1f063b7595912e4164c7b6e1f33cfec6fab9c7e8e96297646230a22 glibc-test.patch"