aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nsss/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-03 02:00:31 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-03 02:16:58 -0300
commit1c50666679a3f335d1f0cf9b5c9981c1fbe7ffe8 (patch)
tree9c2616af14c4fd027db4439e5a76d320d7ddced3 /testing/nsss/APKBUILD
parent53fa7133fed797614213f988acbe28404fe4ccf1 (diff)
downloadaports-1c50666679a3f335d1f0cf9b5c9981c1fbe7ffe8.tar.bz2
aports-1c50666679a3f335d1f0cf9b5c9981c1fbe7ffe8.tar.xz
testing/nsss: new aport
https://skarnet.org/software/nsss A small and statically linkable alternative to Name Service Switch
Diffstat (limited to 'testing/nsss/APKBUILD')
-rw-r--r--testing/nsss/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/nsss/APKBUILD b/testing/nsss/APKBUILD
new file mode 100644
index 0000000000..e2ceaf765b
--- /dev/null
+++ b/testing/nsss/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=nsss
+pkgver=0.0.2.2
+pkgrel=0
+pkgdesc=" A small and statically linkable alternative to Name Service Switch"
+url="https://skarnet.org/software/nsss"
+arch="all"
+license="ISC"
+makedepends="skalibs-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://skarnet.org/software/nsss/nsss-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --enable-shared \
+ --enable-static \
+ --disable-allstatic \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --libexecdir="/usr/lib/$pkgname" \
+ --with-dynlib=/lib
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+doc() {
+ default_doc
+ mkdir -p "$subpkgdir/usr/share/doc"
+ cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
+}
+sha512sums="6cece92d0aa48eb47baa321d20b77fe48d7255dd07d2d4226c9319d817e6355f72277c119ef9aa2dab8c65e144a9c13ca9df4d55120c250ca048c109ee16380f nsss-0.0.2.2.tar.gz"