aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nut/upsmon.initd
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-04-21 16:37:33 +0300
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-06-02 08:02:44 +0000
commit2275192021130da8e3bed22be2cd653ce9793a47 (patch)
treed334efe6a5bb25a24c2462d72e973071c06b3a0d /testing/nut/upsmon.initd
parent1d0d9aded485e650569d95c479574a1ffc6fdb9a (diff)
downloadaports-2275192021130da8e3bed22be2cd653ce9793a47.tar.bz2
aports-2275192021130da8e3bed22be2cd653ce9793a47.tar.xz
testing/nut: fix user creation in post-install
-- add nut home dir /var/lib/nut used for scheduler fix libexec and driver dirs (libexec -> lib) add using dns in init-scripts remove conf.d files from package because it have no sence for now cleanups in APKBUILD and init-scripts
Diffstat (limited to 'testing/nut/upsmon.initd')
-rw-r--r--testing/nut/upsmon.initd7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/nut/upsmon.initd b/testing/nut/upsmon.initd
index 62adaf22dd..4a7efe8ba4 100644
--- a/testing/nut/upsmon.initd
+++ b/testing/nut/upsmon.initd
@@ -1,19 +1,20 @@
#!/sbin/openrc-run
-name=nut-monitor
+name="UPS Monitor"
pidfile=/run/upsmon.pid
command=/usr/sbin/upsmon
required_files="/etc/nut/nut.conf /etc/nut/upsmon.conf"
extra_started_commands="reload"
+start_stop_daemon_args="--quiet"
depend() {
- use net
. /etc/nut/nut.conf
case $MODE in
standalone|netserver)
need nut-upsd
;;
esac
+ use net dns
}
start_pre() {
@@ -29,6 +30,6 @@ start_pre() {
reload() {
ebegin "Reloading $name"
- start-stop-daemon --signal HUP --pidfile ${pidfile}
+ start-stop-daemon --signal HUP --pidfile $pidfile
eend $?
}