aboutsummaryrefslogtreecommitdiffstats
path: root/testing/obfs4proxy/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-02-20 23:22:07 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-02-20 23:22:18 +0100
commit5fa390a4d7991c9c67920076976897675b7a18f9 (patch)
tree1e29ba9aa8d5c2104699ef0c0ddcb9d6d6a9a454 /testing/obfs4proxy/APKBUILD
parenta2601d0061b913685c8af07437b4dd39d8b86772 (diff)
downloadaports-5fa390a4d7991c9c67920076976897675b7a18f9.tar.bz2
aports-5fa390a4d7991c9c67920076976897675b7a18f9.tar.xz
Revert "testing/obfs4proxy: initial package commit based on version 0.0.7"
This reverts commit 086595299761c604747f7ed0fc7ecabe6fc365b1. This aport downloads dependencies from internet without any verification ("go get"), i.e. the build is not deterministic. This is considered as a very bad practice and it's not acceptable for Alpine packages.
Diffstat (limited to 'testing/obfs4proxy/APKBUILD')
-rw-r--r--testing/obfs4proxy/APKBUILD28
1 files changed, 0 insertions, 28 deletions
diff --git a/testing/obfs4proxy/APKBUILD b/testing/obfs4proxy/APKBUILD
deleted file mode 100644
index 9e74ad5bb2..0000000000
--- a/testing/obfs4proxy/APKBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# Contributor: Katie Holly <holly@fuslvz.ws>
-# Maintainer: Katie Holly <holly@fuslvz.ws>
-pkgname=obfs4proxy
-pkgver=0.0.7
-pkgrel=0
-pkgdesc="pluggable transport proxy for Tor, implementing obfs4"
-url="https://gitweb.torproject.org/pluggable-transports/obfs4.git/"
-arch="x86_64 x86"
-license="BSD-3-Clause"
-makedepends="go"
-options="!strip"
-install=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/Yawning/obfs4/archive/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/obfs4-$pkgname-$pkgver
-
-build() {
- cd "$builddir"
- go get -d ./$pkgname
- go build -v -o ./$pkgname-executable ./$pkgname
-}
-
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
- install -Dm755 $pkgname-executable "$pkgdir"/usr/bin/$pkgname
-}
-
-sha512sums="57b71138a139b1821cf58c8e1965f207a6164a046bbfc8d6da828351d4f5bf4ecfb63ca5c69dba834c4e3a72362089d2a7fd296278115c0cae1c53c51d1b124d obfs4proxy-0.0.7.tar.gz"