aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-fileutils
diff options
context:
space:
mode:
authorFernando Casas Schössow <casasfernando@outlook.com>2019-02-07 20:22:21 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 14:02:16 +0000
commite6af149107ed749a1e67f759c79c7a07840ecc03 (patch)
tree78513a62b7baa0782f31e176fe36cc0645e99b3c /testing/ocaml-fileutils
parent62ccc120447793b94d4898f4f9d205683eb2d826 (diff)
downloadaports-e6af149107ed749a1e67f759c79c7a07840ecc03.tar.bz2
aports-e6af149107ed749a1e67f759c79c7a07840ecc03.tar.xz
testing/ocaml-fileutils: new aport
https://github.com/gildor478/ocaml-fileutils OCaml library for common file and filename operations
Diffstat (limited to 'testing/ocaml-fileutils')
-rw-r--r--testing/ocaml-fileutils/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/ocaml-fileutils/APKBUILD b/testing/ocaml-fileutils/APKBUILD
new file mode 100644
index 0000000000..931dd6f54f
--- /dev/null
+++ b/testing/ocaml-fileutils/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Fernando Casas Schossow <casasfernando@outlook.com>
+# Maintainer: Fernando Casas Schossow <casasfernando@outlook.com>
+pkgname=ocaml-fileutils
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="OCaml library for common file and filename operations"
+url="https://github.com/gildor478/ocaml-fileutils"
+arch="aarch64 ppc64le x86_64"
+license="LGPL-2.1-or-later-WITH-linking-exception"
+makedepends="ocaml ocaml-ocamldoc ocaml-ounit-dev ocamlbuild ocaml-compiler-libs ocaml-findlib-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/gildor478/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ export OCAMLPARAM="safe-string=0,_"
+ ocaml setup.ml -configure --prefix /usr --destdir "$pkgdir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ export DESTDIR="$pkgdir"
+ export OCAMLFIND_DESTDIR="$DESTDIR/usr/lib/ocaml"
+ mkdir -p "$OCAMLFIND_DESTDIR" "$OCAMLFIND_DESTDIR/stublibs"
+ make install
+ install -D -m644 COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/COPYING.txt"
+}
+
+sha512sums="35aa175ae8a024fe6719716cfa6769a72d8e36fc3dd743da12c9037aa52a1699b12462ab78f1341fb5f2ca25e7935d73b9fb3648161d88771f8d35f7480126f7 ocaml-fileutils-0.4.4.tar.gz"