aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-gen
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-25 00:31:33 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-25 01:15:11 -0300
commit55a9fdb293a2f21a59b7ec18f1ef0dd04a4cd116 (patch)
treea6dbec9d1458ab736ebf232f8797a18fcf1944ca /testing/ocaml-gen
parentefc3db31fed77e74075918f40cc2a551c9e934b3 (diff)
downloadaports-55a9fdb293a2f21a59b7ec18f1ef0dd04a4cd116.tar.bz2
aports-55a9fdb293a2f21a59b7ec18f1ef0dd04a4cd116.tar.xz
testing/ocaml-gen: upgrade to 0.5.2
Diffstat (limited to 'testing/ocaml-gen')
-rw-r--r--testing/ocaml-gen/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/testing/ocaml-gen/APKBUILD b/testing/ocaml-gen/APKBUILD
index 7978eb44a6..ea4e5572bf 100644
--- a/testing/ocaml-gen/APKBUILD
+++ b/testing/ocaml-gen/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-gen
_pkgname=gen
-pkgver=0.5.1
+pkgver=0.5.2
pkgrel=0
pkgdesc="Simple, efficient iterators for OCaml"
url="https://github.com/c-cube/gen/"
@@ -12,26 +12,23 @@ depends="ocaml-runtime"
makedepends="dune ocaml ocaml-findlib opam"
options="!check" # XXX: tests require additional dependencies we don't have yet
subpackages="$pkgname-dev"
-source="https://github.com/c-cube/$_pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/c-cube/$_pkgname/archive/$pkgver/gen-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
jbuilder build @install
}
check() {
- cd "$builddir"
jbuilder runtest
}
package() {
- cd "$builddir"
-
mkdir -p "$pkgdir"/usr/lib/ocaml
jbuilder install \
- --destdir="$pkgdir"/usr \
- --libdir="$pkgdir"/usr/lib/ocaml
+ --destdir="$pkgdir" \
+ --prefix=/usr \
+ --libdir=/usr/lib/ocaml
# There's just a readme and changelog.
rm -Rf "$pkgdir"/usr/doc
@@ -53,4 +50,4 @@ dev() {
mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
}
-sha512sums="4576899776cfb3e62bc9b3703cca6024cc18ef12a1e2d1bf2a675c5a8d9833c0feac829c2254d0f2227d06eea5de831a4f52aae162ce53e4c7168e553b7ce873 ocaml-gen-0.5.1.tar.gz"
+sha512sums="c84e5ea0c9b3a678b6a5c935eacf91265a79b68a48375c44aa5f159d4cb02283c1be0786e172a153666c670bc7ee37b931004b8747a99e5f4ab90ca63e097ff5 ocaml-gen-0.5.2.tar.gz"