aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-lambda-term
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-07 00:41:55 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-07 01:33:56 +0100
commitde9a548c4a93e2562fd90c84172940d595ec4ec6 (patch)
tree40c8ab435e9cb6421c55d676d3acd3297a489746 /testing/ocaml-lambda-term
parent91664d6f39355dc70dd556290a7153c9d22a61dd (diff)
downloadaports-de9a548c4a93e2562fd90c84172940d595ec4ec6.tar.bz2
aports-de9a548c4a93e2562fd90c84172940d595ec4ec6.tar.xz
testing/ocaml-lambda-term: new aport
https://github.com/diml/lambda-term Terminal manipulation library for OCaml
Diffstat (limited to 'testing/ocaml-lambda-term')
-rw-r--r--testing/ocaml-lambda-term/APKBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/testing/ocaml-lambda-term/APKBUILD b/testing/ocaml-lambda-term/APKBUILD
new file mode 100644
index 0000000000..e23527c1e5
--- /dev/null
+++ b/testing/ocaml-lambda-term/APKBUILD
@@ -0,0 +1,67 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ocaml-lambda-term
+_pkgname=lambda-term
+pkgver=1.12.0
+pkgrel=0
+pkgdesc="Terminal manipulation library for OCaml"
+url="https://github.com/diml/lambda-term"
+arch="all"
+license="BSD-3-Clause"
+depends="ocaml-camomile ocaml-lwt ocaml-lwt-react ocaml-zed"
+makedepends="
+ dune
+ ocaml
+ ocaml-camomile-dev
+ ocaml-lwt-dev
+ ocaml-lwt-react
+ ocaml-findlib
+ ocaml-react-dev
+ ocaml-result-dev
+ ocaml-zed-dev
+ opam
+ "
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.bz2::https://github.com/diml/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tbz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ jbuilder build @install
+}
+
+check() {
+ cd "$builddir"
+ jbuilder runtest
+}
+
+package() {
+ cd "$builddir"
+
+ opam-installer -i \
+ --prefix="$pkgdir/usr" \
+ --libdir="$pkgdir/usr/lib/ocaml" \
+ --docdir="$pkgdir/doc" \
+ --mandir="$pkgdir/usr/share/man" \
+ $_pkgname.install
+
+ # There's just a readme and changelog.
+ rm -Rf "$pkgdir"/doc
+
+ # Remove annotation files and sources.
+ cd "$pkgdir"/usr/lib/ocaml/$_pkgname
+ rm -f *.cmt* *.ml
+}
+
+dev() {
+ default_dev
+ depends="$pkgname=$pkgver-r$pkgrel"
+ local sitelib="usr/lib/ocaml/$_pkgname"
+
+ cd "$pkgdir"/$sitelib
+
+ mkdir -p "$subpkgdir"/$sitelib
+ mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
+}
+
+sha512sums="d2f49f32d2b0b260f609f0674ff1060ddb456ad5a37e87659d0f2005720b1f5f2da12ca0951d1ae959f7d4dd089bd0d7526fd1702b2a3b00164591ed8d37f8ae ocaml-lambda-term-1.12.0.tar.bz2"