aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-lwt
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-03-14 17:17:23 +0000
committerJakub Jirutka <jakub@jirutka.cz>2018-03-16 01:38:17 +0100
commit561ee68a37add471ba206c25a29197498802cbed (patch)
tree7fea3633b3aa4fcb2ac460ba3c908dafd46c1530 /testing/ocaml-lwt
parent6497dce3d3c66b9b36c702890340e8d8da271b8d (diff)
downloadaports-561ee68a37add471ba206c25a29197498802cbed.tar.bz2
aports-561ee68a37add471ba206c25a29197498802cbed.tar.xz
testing/ocaml-lwt: avoid ocaml-lambda-term ppc64 build failure
...by inlining result_lseek functions.
Diffstat (limited to 'testing/ocaml-lwt')
-rw-r--r--testing/ocaml-lwt/APKBUILD8
-rw-r--r--testing/ocaml-lwt/result_lseek_noinline.patch20
2 files changed, 25 insertions, 3 deletions
diff --git a/testing/ocaml-lwt/APKBUILD b/testing/ocaml-lwt/APKBUILD
index c316c0c3ac..5a0c2f9da9 100644
--- a/testing/ocaml-lwt/APKBUILD
+++ b/testing/ocaml-lwt/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ocaml-lwt
_pkgname=lwt
pkgver=3.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="OCaml promises and concurrent I/O"
url="https://github.com/ocsigen/lwt"
arch="all !x86 !armhf !s390x" # limited by ocaml aport
@@ -27,7 +27,8 @@ makedepends="$depends_dev
opam
"
subpackages="$pkgname-dev $pkgname-doc $pkgname-react"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ocsigen/$_pkgname/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ocsigen/$_pkgname/archive/$pkgver.tar.gz
+ result_lseek_noinline.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -86,4 +87,5 @@ dev() {
mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
}
-sha512sums="ddea7561c12b0c7f1ee557462766c2f04d08b9e452fac14a906c17aba643be90299a6aa0aee20dfc16031eca4f557bfc0e7f6779643eeaee2337129f77da836d ocaml-lwt-3.2.1.tar.gz"
+sha512sums="ddea7561c12b0c7f1ee557462766c2f04d08b9e452fac14a906c17aba643be90299a6aa0aee20dfc16031eca4f557bfc0e7f6779643eeaee2337129f77da836d ocaml-lwt-3.2.1.tar.gz
+dc3abce70b3ad022066e8023a9b37346df0ecbbc6351186cc24b569189142ad3e7e32f27c33a4378f11ec8c40df5c96f4c37190ca4797bc228ca8943f53cf5bf result_lseek_noinline.patch"
diff --git a/testing/ocaml-lwt/result_lseek_noinline.patch b/testing/ocaml-lwt/result_lseek_noinline.patch
new file mode 100644
index 0000000000..2e2fd1552d
--- /dev/null
+++ b/testing/ocaml-lwt/result_lseek_noinline.patch
@@ -0,0 +1,20 @@
+--- a/src/unix/unix_c/unix_lseek_job.c
++++ b/src/unix/unix_c/unix_lseek_job.c
+@@ -92,7 +92,7 @@
+ }
+
+ /* The function building the caml result. */
+-static value result_lseek(struct job_lseek* job)
++__attribute__((noinline)) static value result_lseek(struct job_lseek* job)
+ {
+ value result;
+ /* Check for errors. */
+@@ -113,7 +113,7 @@
+ }
+
+ /* The function building the caml result. */
+-static value result_lseek_64(struct job_lseek* job)
++__attribute__((noinline)) static value result_lseek_64(struct job_lseek* job)
+ {
+ value result;
+ /* Check for errors. */