aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-uchar
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-10 20:04:25 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-11 21:37:43 +0100
commit9d718c898d87f7e490603409c712164f4803ebfc (patch)
tree83b82f1f3460287ac5306a1e3734b3f094d5a7dc /testing/ocaml-uchar
parent5e3b7b170f4478bd6d19dc53464a0fdc58bb3ae4 (diff)
downloadaports-9d718c898d87f7e490603409c712164f4803ebfc.tar.bz2
aports-9d718c898d87f7e490603409c712164f4803ebfc.tar.xz
testing/ocaml-uchar: new aport
https://github.com/ocaml/uchar Compatibility library for OCaml's Uchar module
Diffstat (limited to 'testing/ocaml-uchar')
-rw-r--r--testing/ocaml-uchar/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/ocaml-uchar/APKBUILD b/testing/ocaml-uchar/APKBUILD
new file mode 100644
index 0000000000..02c200b55a
--- /dev/null
+++ b/testing/ocaml-uchar/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+#
+# NOTE: This is just a dummy module to satisfy dependencies, uchar is provided
+# directly by ocaml since 4.03.
+pkgname=ocaml-uchar
+_pkgname=uchar
+pkgver=0.0.2
+pkgrel=0
+pkgdesc="Compatibility library for OCaml's Uchar module"
+url="https://github.com/ocaml/uchar"
+arch="all !x86 !armhf !s390x" # limited by ocaml aport
+license="LGPL-2.1-WITH-linking-exception"
+depends="ocaml-runtime"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
+makedepends="ocaml ocamlbuild opam"
+options="!check" # no tests provided
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/uchar/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ocaml pkg/build.ml \
+ native=true \
+ native-dynlink=true
+}
+
+package() {
+ cd "$builddir"
+
+ opam-installer -i \
+ --prefix="$pkgdir/usr" \
+ --libdir="$pkgdir/usr/lib/ocaml" \
+ $_pkgname.install
+}
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/lib/ocaml/$_pkgname
+}
+
+sha512sums="487a9706cf9dfc9b9c94442a51766cc211687d6ebcb4dd3c94d09cb1ed6d7fd61e966e91a4121fe2d1681b2fd6bfee9079d3bccccdb6d65ba2111524ab5dd1bc ocaml-uchar-0.0.2.tar.gz"