aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocfs2-tools/ocfs2console-explicitly-specified-link-libraries.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-23 21:56:11 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-23 22:18:39 +0200
commit4f24ccb86c8a9d8b73bbcb2d2d4ba4bfceb5c96b (patch)
tree710d95ee14b9815b21685d08b1d60ef864d148fe /testing/ocfs2-tools/ocfs2console-explicitly-specified-link-libraries.patch
parentada13b6998155f1425ec53c9a6ceeac17a5cb7cd (diff)
downloadaports-4f24ccb86c8a9d8b73bbcb2d2d4ba4bfceb5c96b.tar.bz2
aports-4f24ccb86c8a9d8b73bbcb2d2d4ba4bfceb5c96b.tar.xz
testing/ocfs2-tools: rewrite aport and upgrade to 1.8.5
Note: We use the same ("unofficial"?) upstream as Fedora.
Diffstat (limited to 'testing/ocfs2-tools/ocfs2console-explicitly-specified-link-libraries.patch')
-rw-r--r--testing/ocfs2-tools/ocfs2console-explicitly-specified-link-libraries.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/ocfs2-tools/ocfs2console-explicitly-specified-link-libraries.patch b/testing/ocfs2-tools/ocfs2console-explicitly-specified-link-libraries.patch
new file mode 100644
index 0000000000..4441d0bf99
--- /dev/null
+++ b/testing/ocfs2-tools/ocfs2console-explicitly-specified-link-libraries.patch
@@ -0,0 +1,48 @@
+From e686b8013a14b9b28e77bf08457d426f45689e9d Mon Sep 17 00:00:00 2001
+From: Robin Lee <cheeselee@fedoraproject.org>
+Date: Mon, 29 Jan 2018 15:01:32 +0800
+Subject: [PATCH] ocfs2console: explicitly specified link libraries
+
+Patch-Source: https://src.fedoraproject.org/rpms/ocfs2-tools/blob/f28/f/0001-ocfs2console-explicitly-specified-link-libraries.patch
+---
+ ocfs2console/ocfs2interface/Makefile | 11 +++++++----
+ 1 file changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/ocfs2console/ocfs2interface/Makefile b/ocfs2console/ocfs2interface/Makefile
+index 54094559..7c7c9b1c 100644
+--- a/ocfs2console/ocfs2interface/Makefile
++++ b/ocfs2console/ocfs2interface/Makefile
+@@ -19,6 +19,9 @@ LIBO2CB_LIBS = -L$(TOPDIR)/libo2cb -lo2cb -ldlm_lt
+ else
+ LIBO2CB_LIBS = -L$(TOPDIR)/libo2cb -lo2cb
+ endif
++ifneq ($(BUILD_CMAP_SUPPORT),)
++LIBO2CB_LIBS += -lcmap
++endif
+ LIBO2CB_DEPS = $(TOPDIR)/libo2cb/libo2cb.a
+
+ ifdef HAVE_BLKID
+@@ -94,16 +97,16 @@ INSTALL_RULES = install-pylib
+ DIST_FILES = $(PLIST_CFILES) $(PLIST_HFILES) $(GIDLE_CFILES) $(OCFS2_CFILES) $(O2CB_CFILES) $(PYSRC) $(addsuffix .in,$(BUILT_PYSRC))
+
+ plistmodule.so: $(PLIST_OBJS) $(LIBOCFS2_DEPS) $(LIBO2DLM_DEPS) $(LIBO2CB_DEPS) $(BLKID_DEPS)
+- $(LINK) -shared $(LIBOCFS2_LIBS) $(LIBO2DLM_LIBS) $(LIBO2CB_LIBS) $(BLKID_LIBS) $(COM_ERR_LIBS) $(GLIB_LIBS)
++ $(LINK) -shared $(LIBOCFS2_LIBS) $(LIBO2DLM_LIBS) $(LIBO2CB_LIBS) $(BLKID_LIBS) $(COM_ERR_LIBS) $(GLIB_LIBS) $(shell python-config --libs)
+
+ gidlemodule.so: $(GIDLE_OBJS)
+- $(LINK) -shared $(GLIB_LIBS)
++ $(LINK) -shared $(GLIB_LIBS) $(shell python-config --libs)
+
+ ocfs2module.so: $(OCFS2_OBJS) $(LIBOCFS2_DEPS) $(LIBO2DLM_DEPS) $(LIBO2CB_DEPS)
+- $(LINK) -shared $(LIBOCFS2_LIBS) $(LIBO2DLM_LIBS) $(LIBO2CB_LIBS) $(COM_ERR_LIBS) $(UUID_LIBS)
++ $(LINK) -shared $(LIBOCFS2_LIBS) $(LIBO2DLM_LIBS) $(LIBO2CB_LIBS) $(COM_ERR_LIBS) $(UUID_LIBS) $(shell python-config --libs)
+
+ o2cbmodule.so: $(O2CB_OBJS) $(LIBO2CB_DEPS)
+- $(LINK) -shared $(LIBO2CB_LIBS) $(COM_ERR_LIBS)
++ $(LINK) -shared $(LIBOCFS2_LIBS) $(LIBO2CB_LIBS) $(COM_ERR_LIBS) $(shell python-config --libs)
+
+ install-pylib:
+ $(SHELL) $(TOPDIR)/mkinstalldirs $(DESTDIR)$(pyexecdir)/ocfs2interface
+--
+2.13.6
+